Secure Shopping - Unable to install (SOLVED)

Trying to install the latest CSS version 151 by first updating, then by uninstalling the previous version 142 and doing a fresh install
Both methods result in the error: ‘The system cannot open the device or file specified’ as shown

Now of course I cannot install the previous version of CSS, even when included with a clean install of CIS 6744 on this system
Any help appreciated . . .

Is CSS still listed in programs and features? Are any files/folders relating to CSS still found in Programdata\Comodo and in Program Files (x86)\Comodo? If you find any installers or setups in those folders run it to see if it gives you the option to repair.

It’s not listed in Programs and the only trace / folder is the latest installer in Program Data/Comodo, which when run, launches a full install attempt and then errors out

I’m going to try a completely clean CIS install and see what happens

Edit: Nothing helps . . deleted all CSS Registry entries. Clean install - error. Clean install of CIS - error

Nothing has worked . . . did a clean install of the RC release 6778, with KillSwitch installing and working fine along with Virtual Desktop

But Secure Shopping - no luck and errors out again

Edit: Went back to making this system more ‘normal’. The Environmental Variables are pointed to a Ram Drive (R - away from the OS’s SSD), so I changed them back to the C Drive, rebooted and tried again - all worked flawlessly. I’ve come across that very rarely in the last few years as most installs will reference the system settings, or give a more detailed warning - but not this time!

It may be worth fixing that little glitch for the future, as I can’t be the only one using a Ram Drive for that purpose 8)