Secure DNS Server not loading Google


Not sure if this is a Secure DNS issue or a CD issue but for the last hour or so I can’t open any Google search pages if I have the secure DNS servers manually entered on my laptop. Also, if I check the box in CD Options which says " Enable malware domain filtering (Comodo Secure DNS)" I can’t get Google, even if I have DNS set to automatically obtain DNS or if I manually enter another set of DNS numbers.

I want to use Secure DNS but this renders it useless.

Having the same issue here. and 71.22 seem to be working. I had to add one to my router to get browsing back.

Interesting! I’ve tried these earlier with no luck, however, they now work as do the other settings in CD. It’s almost as if the servers local to the UK were ‘down’ but there seems no way to find out. I’ll monitor and report back if it happens again.

Please let me know if you have any more issues.