Secure DNS creates problem accessing genuine banking site [v6]

Not sure if this is a bug or not but since last Friday I have experienced the following problem. My default browser is Ice Dragon although I also have IE10, Firefox and Dragon installed as well and all kept up to date. My OS is Windows 7 and I made a clean install of Comodo v6 from v5.12 about a month ago. last Friday using Ice Dragon I attempted to log in to my online banking account at the NatWest site here in the UK. I have done this about once weekly for a long time with Ice Dragon now but previously also with Dragon and Firefox without any problems. My usual bookmark opened up on the NatWest opening screen but when I clicked on the Log In button in the purple box top right on that page it timed out after a period it timed out and I got the appropriate message to this occurence. After getting the same response a few times I tried with each of my other installed browsers getting the same response with them as well. All my other bookmarks are working the only problem is with the NatWest log in option.

I thought at first that it must be a security issue and so I checked out my NoScript, Ghostery, Peer Block programs etc, etc but found nothing untoward in any of them and as I say all other internet traffic is working fine. I went to the NatWest online help and found no solution there either I phoned them and the chap I talked to couldn’t figure it out either but assured me that there wasn’t a problem with their site. I then tried using the links to the sandboxed browser links from the widget but still couldn’t log in. I next tried the Virtual Kiosk feature imported shortcuts to IE10, Firefox and Ice Dragon and started with the default Dragon browser but still couldn’t log in to my account from the NatWest screen.

I closed the Virtual Kiosk and as a last attempt tried Firefox and hey presto I got logged in. I checked my account and then exited. I then found that I could log in to my NatWest account via Dragon and IE10 as well but not with Ice Dragon. I then went on Google and tried with no luck to find a reason for the problem I was having. This morning I had to reboot my PC as part of a Video card update and later I went to sign in to my bank account only to find that I had the same problem again. I went through the whole rigamarole again and still coudn’t get logged in. I thought on what I had done yesterday prior to getting access then and remembered that I had come from the Virtual Kiosk before opening the normal version of Firefox. I did this again with no luck the first time but then attempted something which turned out to be a solution for me.

If I open the Virtual Kiosk and then leave it by using the return to Windows option offered I can then use the normal desktop shortcuts to Firefox, Dragon and IE10 (Ice Dragon does not work for some reason) to go to the NatWest site and log in to my account as I normally do. If however I leave the Virtual Kiosk by the Exit option I cannot connect to the sign in screen at NatWest and cannot access my account. I have absolutely no idea why my browsers are behaving in this manner but have tested it a few times now and crazy as it sounds that is what is happening. Could this be a bug and is there a work round as I would prefer to keep using Ice Dragon as my default browser but cannot at the moment due to this glitch. Below I have left a shortcut to the NatWest site. Could one of you developers attempt to do what I have tried to explain and see if the same happens for you. You do not need an account there to log in.

Thank you very much for your issue report.

We would very much appreciate it if you would be kind enough to edit your report to put it in the standard format and add any additional information requested, as this will make it much easier for the developers to diagnose and fix the problem.

In particular please make sure you append a process list taken at the time you are having a problem logging in, showing the browser instance you are using to log in.

The reasons we need all the information in the format, though they may not seem directly relevant to the issue are explained here.

If you are able to do this we will forward this post to the format verified board, where it is more likely to get looked at by developers. You can find assistance using red links in the format and here. If you need further help please ask a mod. If you do not add the information after a day or two we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report in standard format or not. However we may remind you if we think a bug of particular importance.

Many thanks again


PM sent

I am able to reproduce that Comodo Ice Dragon will not go past the initial screen and times out.
I was able to get to the login screen fine with Firefox And Comodo Dragon.I tried Ice Dragon outside and inside the virtual kiosk and it just times out.

Is this a IceDragon bug do you think then, or a CIS bug? (Try disabling CIS maybe to see). If a CIS bug, and the OP won’t do a report would you mind doing one DrHaze?

Problem Solved. It was neither a bug with any of the browsers or the Virtual Kiosk but with the Comodo Secure DNS servers. After trying countless solutions to this problem I came to the conclusion that it couldn’t be any of them as it affected all browsers. The only thing I could think of that all browsers have in common is the DNS servers. I changed the SEcure DNS servers over to Open DNS and hey presto problem solved immediately. Now I can sign into Natwest on all of them without any drawbacks. I went to the Comodo DNS forum here earlier to report it and found that I am not alone in having problems with them. Anyway thanks for taking the time to read the post above and any replies.

THanks for the feedback, much appreciated.

I’ll forward this to the DNS Board, so it can be acted on.

Best wishes