Secure Connection Problem

I’m having major troble getting to my e-mail & other secure connection webpages. It keeps saying “Secure Connection Failed.” Please tell me how to fix this please.

[attachment deleted by admin]

Somehow it’s fixed now. But if it happens again, I’ll post it here.


I am using Comodo Dragon 17.4 as my default browser.

When Using Cisco AnyConnect VPN Client, it launches Dragon after the login authentication. It however causes Dragon to crash with the “Aw Snap” prompt. I tried switching to another browser as default and the page loads correctly in that browser - without error.

As my preference is Comodo Dragon, I wish to resolve this issue.

Any Suggestions?

P.S. All security settings are the same for both browsers.

I got another secure connection problem w/ Firefox. How does this get fixed?

[attachment deleted by admin]

It means that FF cannot check if the certificate is revoked or not. It could be a problem with the certificate’s authority OCSP server or a hiccup in the route from your pc to the OCSP server.

See if the problem persists.

Have you enabled OCSP hard fail in firefox? (image)

[attachment deleted by admin]

It was already enabled & the problem still persists.

[attachment deleted by admin]

That’s one of the reasons for your ‘problem’!

I tried disabling it & it works now, thanks.