Schizophrenic version numbers from to

I am perplexed as to which version I currently have installed!

The reason being that from version, every update and reinstall does not change this number in the about box.

I have had continued failures of the automatic update as described elsewhere in this forum and I am on my second clean install.

The last install file I have downloaded is called CFP_Setup_3.0.18.309_XP_Vista_x32.exe

However through all this the about dialogue always shows!!!

The current version number of cpf.exe is, and this is after an automatic update.

So, my question is what version do I have and what’s going on?

And it looks like the automatic update is still not working!!!.

Before the last clean install, I scanned my hard drive fro any residule files, registry entries with comodo in them.

Hi GraemeM

Check the file properties of CFP.exe it should show you a version of if you have the latest version.


I have the same problem. My “About” dialog show version but if I check cpf.exe the file version is It is a bit confusing. I have also tried to uninstall an reinstall several times. I have Windows Vista Basic.

Hi h.o.nordin

Welcome to the Comodo Forums

It looks like you have found a little bug in the about dialog. You have version


I have the same problem as my “about” dialog says i have but when i check the file properties of CFP.exe it says i have installed. It´s very frustating not to know which version that is currently installed, is this something the comodo staff is working on to resolve?

Same problem here guys.probably is whats is behind the constant prompt to update and its been going on since i can remember.

Could everyone who is having this problem please fill out the bug report form found here .



[quote author=GraemeM link=topic=20110.msg137870#msg137870 date=1203710956]
I am perplexed as to which version I currently have installed!

Hi again!
I have tried to investigate this problem a little more.

  1. CPU 32 bit

  2. Windows Vista Home Basic up to date 2008-02-26

  3. UAC on, Avast antivirus, PC Tools Spyware Doctor (Google version) and Windows Deftender.

  4. First an update from Comodo to The “About dialog” show version after update and restart of the system.

  5. Later several uninstall and clean installs to version The “About dialog” show’s always The file version of cpf.exe is
    I tried to inactivate the UAC and after that the about dialog show’s the right version
    I activated the UAC again and the About dialog is back to
    After a restart of the system I get a popup who says that a “windows system file is change” (Validation of Vista failed).
    I tried to uninstall Comodo but the “Control panel” is empty, uninstall unavailable.
    After I disable the firewall and defence+, restart of system the Control panel works again and I uninstalled the Comodo fireewall.
    Now when I have the Windows firewall enabled and the Comodo firewall not installed all works as it should.
    It Seems that Comodo has some problem with the UAC of Windows Vista.

  6. Standard install with Defence+ enabled. No special setttings.

I wait for an update to solve this issue. Meanwhile I have to trust the Windows firewall.

please look at HKEY_LOCAL_MACHINE\SOFTWARE\ComodoGroup\CDI\1 in your registry and cfpver.dat in COMODO\Firewall
Those files/registy keys hold CFP version numbers. Please report back any info abou them and the one mentioned in bugreport guidelines.

HKEY_LOCAL_MACHINE\SOFTWARE\ComodoGroup\CDI\1\Product Version=
cfpver.dat =
The “About box” show me (UAC enabled)
After disable the UAC, “About box” show me

Ah I see, you created anothe account.
Just on thing then…

If you turn UAC on does cfp Version revert back?

BTW Some users reported that turning UAC off cause CFP updater to fail to acknowledge the installed version thus continually asking for updates.
Your findings seem to contradict theirs. anyway after a reboot can you please run a manual update an tell me if it works corretly with UAC off?

If you turn UAC on does cfp Version revert back?
Yes, it show me again.

The question about maual update:
With UAC off: There are no updates available.
With UAC on: Updates are available. Please click on ‘Next’ button to start the update process.


Oh my…! Please Join the updater topic too

You just reported the opposite other member experienced.

I guess we need other infos about this.