Scheduler dosn't work

Hi, I need to post this case as I didn’t find the any relevant information in the forum.

In the scheduler I’ve selected both day and start time - but it doesn’t start
The destination is a NAS disk which has been routed through the “network” and not through a mapped folder

Windows task scheduler was mentioned in another thread. I don’t know if it’s relevant but comodo backup are not listed there.

I’m running
On XP Home edition

Thanks for any ideas.

Did you set the backup job as a service backup, or a user backup?

If you set it up as a service backup, then you need to be logged in as an adminstrator or adminstrator equivalent. Thiswill ensure that the job will run, regardless of which user is logged in at the time. If it was set up as a user backup, the job will only run when the user that set the job up is logged in.

Is the Windows Task Scheduler service running?

Ewen :slight_smile:

Thanks for a quick reply.

The backup job is a service backup.
The user (me) is administrator

But, the windows task scheduler (mstask.exe) is not in the process list. Do you know how I start this process?

Thanks again


The easiest way is to click START → RUN and enter SERVICES.MSC . This will dispay all current services and their status. Find the entry for Task Scheduler and make change itsproperties so it is set to automatically start.

I’ve found a couple of google references to other thngs that could affect the Scheduler service.

Hope this helps,
Ewen :slight_smile:

thanks for your suggestions Ewen!
but, opening services.msc reveals that task scheduler is in automatic mode
so, it seems like the problem is back to comodo backup settings again?

looking forward to any other suggestions

Just to establish a base position - does the task scheduler serivce work fro other apps - i.e. can you schedule other events using it?

Ewen :slight_smile:

Hope you don’t mind me barging in Panic.

Hi cje

In the main GUI of Backup make sure service state is “running”. Then in your backup job be sure you have the “active backup” box checked. You also need to make sure that Windows task scheduler has the user name and password entered if you do not have any other tasks scheduled. If you do and they run, then you can ignore this last item. Are you in Simple copy mode? What happens when you push the test button?


Ewen, there are 3 other “update apps” in TS. Assumingly they are working ok. Do you know any ways to quickly check it? Could it have been blocked by the firewall or a similar secure app?

John, I’ve checked the settings. They are according to you notifications. And yes, I’m in Simple Copy mode.
Test is ok and I it’s no problem to run the backup manually.

This is my first post on this forum, and I guess it indicates that I also have a problem with scheduled backups.
Like cje I have carried out all the appropriate checks. I too am in Simple Copy mode, and the Test backup works fine. I can also make an instantaneous backup without problems. It is only the scheduled backups which are causing me grief.
Being a newbie, and a little uncertain, is it possible I have to leave Comodo Backup running (i.e. window open) all the time to expect it to backup, or is it OK to close the program and still expect it to work? When closed, should I expect to see it in the Task bar?
Any help appreciated


Hi parking, Welcome to the Comodo Forum

No, you do not have to leave Backup running for the scheduler to work. You can close it down completely. It will not be visible in the taskbar unless it is running in the background. Just be sure that you have it set to Backup Type - Service backup, and that the Service state at the top of the GUI says running. And of course the scheduler must be set. Make sure you have windows task scheduler operable as well.


Hi John,

Thanks for the reply. It looks as though “service backup” may have been my problem. I will know after the scheduled backup this evening.

Thanks again

Hi again John,

Well, sad to say, the backup hasn’t worked.
I am running windows XP home. I set the back up to service, and the Service state is “running”. The scheduler is set. I have checked the windows task scheduler as mentioned, and it is set at “automatic”. I presume this is OK.
At the moment I seem to be at the same position that cje was below. His last post was in January. I wonder if he got it working, or gave up?
Would I be better saving to my C drive and then transfer it afterwards?

I’m at your mercy


I find I cannot depend on backup working using the scheduler as stated. I use XP. I have the scheduler set for every evening at 10 PM. If something else is going on, no backup. I think I’m missing something. If I click on it and then minimize it,I see it in the lower right of the task bar and it says ready when I hover over it.


Hi all,
Backup still not working. Looking back over posts I wonder if it is the Administrator login that is incorrect. I am using windows XP home. I am the only person using this PC. I don’t know how to login as administrator.
Would this solve my problem?
I don’t want to get myself in too deep here.



Hi Russell,

For Comodo Backup scheduler and service type backups to work correctly, the udser that defines the backup job and accompanying schedule MUST be the administrator or a member of the Adminstrator group.

you can check this by clicking START → RUN and entering COMPMGMT.MSC

This will open up the Computer Management console. Open up Users and Groups and see what group your current login name is in.

Hope this helps,
Ewen :slight_smile:

HI Panic,

Thanks for your help.
I have opened up computer management as advised, but cannot see Users and Groups (screen dump attached in XL).
I hope I’m not missing the bleeding obvious here, but not sure where to go next.

Thanks again


[attachment deleted by admin]

Hey Russell,

What operating system and version ar your using??

An alternative method, providing you’re using XP, is to open Control Panel and select USER ACCOUNTS. This will display the accounts on the local machine and whether they are an Adminstrator (or equivalent) or a standard user.

Ewen :slight_smile:

HI Ewen,

I have opened the Control Panel>User Accounts, and I AM the administrator.
I am using XP Home with the latest patches.

Things are not looking good for the scheduler.
I should be disciplined enough to do the backup manually, but perhaps less often than desirable.



Hey Russell,

Can you please check if the COMODOBACKUPSERVICES and the Windows TASK SCHEDULER service are both started?

These can be checked by clicking START → RUN, enter services.msc".

Ewen :slight_smile:

HI again Ewen,

I think we are different time zones. I am in Australia, what about you?

I have checked the services.msc, and both Commodobackup and Windows Task Scheduler are Started.