Scheduled Scans Failing

I have been using CIS for a few months now. Other than an initial network connection issue, it has been running fine. However, over the last couple weeks my scheduled scans have been failing. Even manual scans do not seem to work.

What happens with the scheduled scans is that I wake up in the morning to find the scan hanging with an error. I don’t remember exactly what it says but it asks if I want to send an error report. If I say yes, it then gives me another error and says that it can not send the report and it mentions a log file or something to send. Then if I try to stop the scan it pops up a window that says something about not enough resources or memory to stop. Only thing I can then do is exit CIS.

When I do a manual scan it seems to have a memory overflow issue or runs out of resources. Last time I tried a manual scan I came back to my computer to see that it looked like it completed the scan, but it was froze, and things start disappearing on my desktop. I had to reboot.

I am not sure why there would be a resource issue, unless there is something else running that I am not aware of. I have a dual core, 2.53 ghz laptop with 4gb ram, running Win XP. I have not made any changes or installed anything recently that I can remember other than Comodo System Utitlites and Program Manager a few weeks ago.

I ran the Diagnostic Utility, but it says it did not find anything wrong with my installation. I also checked my DEP settings as suggested in another thread. I am typing this from memory and don’t remember the exact messages I got. I am at work now and plan to try another manual scan when I am home and make a note of everything that happens. I figured I would post this to see if anyone can make any suggestions before I try again, or ask me about something I can look for next time I try.

Does anyone know the file the error message was talking about when it failed to send an error report? I am wondering if I would be able to view it and maybe see what might be causing the problem, or can I send it somewhere for someone to take a look at? I remember the file mentioned was somewhere in the Program Files/COMODO directory, but I don’t remember where in there or the file name.

Thanks for any help.

Made a basis paragraph structure for an easier read. Eric

OK, I tried a manual scan and this is what happened…

It only got 1% into it before I got the following pop up…

Ooops! You have just found a bug in COMODO Internet Security. It needs to close. We are sorry for the inconvenience.

Please tell us about this problme to improve the software.

We have created an error report that you can send to us. We will …

I clicked on send error report and then got the following…

The error report was not sent. Please send the file

C:\Documents and Settings\All Users\Application Data\Comodo\CisDumps\


I will do that right after I post this. After that I just try to stop the scan since it’s hanging from the error/bug and I get the following…

Stop failed. Error Code 0x800705aa. Insufficient system resources exist to complete the requested service.

I click OK, but nothing happens. All I can do is exit CIS. CIS will not restart correctly after that and I just reboot. Is this an actual bug? Should I post it in the bug section or report it somewhere?

I ended up doing a clean reinstall following the guide on this site. After doing all that I was able to finally complete a full scan… well sort of. It looks like the scan completed 100%, but then I got some C runtime error. At least it did not tell me I have not completed a scan yet.

But now my weekly schedule scans give me issues. I am not sure if the actual scan completes or what, but when I check the morning of the scan that I have run during the night, my computer is all messed up. There are a bunch of windows that keep popping up, but there is nothing in them, no words or anything. The only thing I can see is a red X and a button. There is only one button and I am guessing it is an OK button. I click on it and another window pops up that looks the same way. After about 5 or 6 windows, I am sitting at what I think is the login window, but again, there are no words. At this point I can not do anything else except hold the power button until it shuts off, and then reboot. Sometimes it performs a disk check and sometimes after it boots up it redownloads all my email again giving me duplicate emails, which is a big pain.

I don’t understand why I am having these issues now. I have used Comodo firewall for over a year with no problems, and after switching to CIS it ran fine for a few months with 2 weekly scheduled scans. Only over the last month or so I have been having these issues.

Just to add again… I am running 32 bit XP, SP3 on a dual core 2.53ghz laptop with 4gb ram. I have not installed anything new over the last couple months that I can remember.

Anyone have any ideas? I really like CIS and the control it gives me, but I think I will have to start searching again for another AV if I keep having these issues.


Please make sure you have the latest version of the C++ runtimes installed on your system. May be that helps to get rid of the C Runtime errors. You can find the downloads here: Latest supported Visual C++ Redistributable downloads | Microsoft Learn .

What version of CIS are you running?

How can I tell what version of the C++ runtimes I have or need?

I have version 5.10.228257.2253

Just install all three of them. They may be needed (in the future). It’s important to have the latest versions of them.

Sometimes the cmdagent.exe (Comodo Internet Security Helper Service) crashes during scanning. It is possible to let it restart after it crashed. Go to Control Panel → Administrative Tools → Services. Look up the service → select it → click right and choose Properties → Recovery → set it to restart in every situation in after 0 minutes and 0 days.

OK, I did all that. We’ll see what happens. If I remember I will try a manual scan tonight, otherwise I have a weekly smart scan scheduled for Tuesday nights.


Well I tried a manual scan last night and the scan completed, but then I got a runtime error and things started acting weird. I was able to restart my computer and everything was OK after that.

I thought I updated the runtime libraries like suggested, but now I am not sure. There are a few things on that site given above. I downloaded and ran the things under the 3 VC++ Redistributable Packages headings, where it mentions libraries for 2010, 2008, and 2005 Service Pack 1 Redistributable Package MFC Security Update. Is that right? The first one (2012) is not for XP so it would not work.

The three mentioned, 2010, 2008 and 2005, were the ones I meant. Were they installed before you ran the manual scan?

Yes, I installed them all before I ran the scan. One thing is that I installed them while at work logged in as a different user, and ran the scan from home. I don’t think that matters though.

Is the other user account an admin account or a limited user account?

They should both be setup with admin rights.

In your start post you are mentioning that approx around the time the scans started to fail you installed Comodo System Utilities and Comodo Program Manager. Would you be willing to uninstall both and see if that makes a difference or not?

I was actually wondering about that… but I figured why would a Comodo product not work with another Comodo product. I’ll give it a shot though and let you know what happens.

By the way, my scheduled smart scan the other day worked fine.

If you still have the CIS dump file you mentioned earlier then please consider filing a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

Reporting of bugs is strictly moderated to make sure Comodo gets clear bug reports. So, please make sure you closely follow protocol. That way your report will certainly be seen by Comodo staff.

I could not find that original dump file, but it should be in my email sent folder since I did send it to the address specified.

I tried to run a manual scan last night. It stopped at 28% and I got the message I got once before that said I found a bug. And again when I tried to send the error report, it wouldn’t send it. All I could do was exit CIS and then restart it. I have this dump file.

Getting back to uninstalling Comodo System Utilities and Program Manager, is there any special way I should uninstall it? I just used their own uninstallers and said to delete the backups and settings.

The email address is not working that’s why I suggested to file a bug report. You can attach the crash log to the bug report.

You can uninstall them using the uninstaller and reboot if requested. In case of doubt you can run this unofficial clean up tool by my colleague Jacob. It’s best to run it when Windows is in Safe Mode.