Scheduled file/maps backup not working

I installed Comodo Backup version 2.2.127000.12 on Windows 7 Enterprise.
I am the only user of the computer and have an admin and a standard account.

I created a simple file/maps backup job and scheduled it to repeat every day 02:00 AM. (This and all attempts mentioned below were done as admin)

The first simple file/maps backup I started manually, which worked fine.
The scheduled file/maps backup however did only copy a fraction of the files. I opened the program: the schedule was gone and no log was written.

I tried to remedy the issue by repairing the program because Comodo Backup repair logged that the windows scheduler was not working properly.
After repair, Comodo Backup did no longer notice any errors. However, problems stayed the same.

Then I uninstalled and installed again. Again: no difference to the problems. Manual running a simple file/maps backup works fine, but as soon as I schedule (silent run, service run, no matter) nothing happens, and nothing is logged.
And everytime I reboot the computer my schedule disappears from the Comodo scheduler and I have to enter the details of the backup job again.

Exporting a schedule as script works, the script is saved on the destination, but does not run the backup job once clicked.

This altogether to me is such strange behavior that I do not know what more to do to trouble shoot.
Advice/help most welcome and appreciated. Thank you for your attention.

Hi

CB scheduled tasks are added automatically as Windows scheduled tasks.

There are a few reasons why a CB scheduled might disappear:

  1. it is deleted by some other program form Windows scheduled tasks
  2. the registry key “HKLM\Software\ComodoGroup\ComodoBackup\ScheduleList” is deleted

Can you reproduce this issue on other machine?

Thanks

Hi Emanual, thank you very much for your response.
I cannot reproduce this on other machines because I have only 1 machine.
[I have a Windows 7 Enterprise license from my employer but work from home on a stand alone machine.]
In the registry the ScheduleList has a value.
If you have any idea how to get the scheduled backup task running I would appreciate very much

Hi
I have the same problem on vista home premium
CB version 2.2.127.000.12
???

I too have the same problem with COMODO BackUP 2.2.127000.12 however I’ve confirmed it on all THREE of my computers and all THREE OS - Window 7 64bit, Vista 32 bit and XP SP3 32 bit.
ALL completely ignore any Schedule request - absolutely NOTHING occurs - no error message, regardless of the Run Mode selected (tried: W7-Service Run, Silent Run, and Autoclick Finish after backup) and have also tried having the CB applcation running in the foreground prior to the sheduled backup time - nothing.
As per the original note - if I ‘Run Now’ manually the backup performs successfully.

PLEASE help!

Please check Windows Task Scheduler service…
It might be turned off.
If it isn’t, select the scheduled task and click “run now”.

Hi Emanual, the Comodo service is running, starting automatically.
The scheduled task however is not listed in the task scheduler. For one reason or another this task is not registered in the list of scheduled tasks. Manually ‘Run now’ works fine, but nothing can be scheduled. For one reason or another Comodo seems unable to register/execute wscheduled tasks and looses the settings.
Hope you can help. As you can tell from other responses on this thread, this issue is not limited to my machine alone, it happens on other machines/configurations as well, so maybe it is an issue with this version of CB?

If you create a new scheduled task, for example a weekly one, does it appear in Windows Task Scheduler?

Thanks

Hi Emanual, a new created scheduld task does not appear in the task scheduler.

Emanuel, I too can confirm Comodo task does NOT appear in the Windows Task Scheduler after creating a new task in COMODO Backup 2.2.127000.12 however within Windows Task Scheduler there are several other items listed that are OS related, such as Defragementation and they do launch correctly daily.
Alsi. I can also confirm when I review the Windows Services, the Comodo BackUp Service is Started, as is also the Task Scheduler service. I’ve confirmed this to be the case on Windows-7 and Vista.

Please advise, what else I could do to assist.
Best Regards

I reviewed a few of the other posts and learned the COMODO Backup Schedule could be exported to a script. I manually created a task in Windows Task Scheduler - set the time to execure to run the .cbs script, which never did happen as the scheduled date/time came an went!
I could not see any notification of an error or any thing else within the Event Viewer.
I did notice within the Windows Task scheduler a prior job named 'CBU taskID 63255749225 5 which I selected and right clicked to RUN but . . . nothing occured! I checked the Event Log again again, only to find nothing of consequence. . . .
What else could I do?

UPDATE - Within Windows Task Scheduler for the COMODObackup task that I manually created (*using .cbs Script exported from the COMODO Backup 2.2.127000.12) I did find a bit of information, in the Task Status log I noticed the Time of the ‘Run End’ is recorded, which confirms the .cbs script only executed for 42 Seconds! Because I know from manually running the script that it works and takes more than 1 hour to complete, this suggests the .cbs script is not launching correctly NOR executing when configured as a Scheduled task - either from within the COMODO Backup application or from within the Windows Task Scheduler. ((Run Start 4/15/2010 4:10:00 PM Run End 4/15/2010 4:10:42 PM))
Please advise if I can provide any further information.

Hi Emanual, do you think you can help with this issue? I have been waiting for a reply, but if these questions are beyond the scope of this forum or cannot be solved by Comodo, please let me know. I can understand and in that case I will look to find another backup solution.
Thank you for your attention.

Hi

There is some further feedback we need.
Please select the scheduled task, right click properties on it.
Go to “Actions” TAB and click “Edit” on the action.
I assume it will be something like “C:\Program Files (x86)\Comodo\Comodo BackUp\CBU.exe /runspecificscheduleitem 63???”
Go to Run in Windows, type “cmd.exe” and hit ENTER,
then type “C:\Program Files (x86)\Comodo\Comodo BackUp\CBU.exe /runspecificscheduleitem 63???” and hit ENTER.
It should open CBU.exe and run the scheduled task, assuming it wasn’t set to run silent.

Please let me know the results.

Thanks

Emanual;
Per you instructions, I assembled the command and thus:
C:\Users\RVM>C:\Program Files (x86)\COMODO\COMODO BackUp\CBU.exe /RunSpecificScheduleItem 63255749225
‘C:\Program’ is not recognized as an internal or external command,
operable program or batch file.

With the quotes:
C:\Users\RVM>“C:\Program Files (x86)\COMODO\COMODO BackUp\CBU.exe /RunSp
ecificScheduleItem 63255749225”
The directory name is invalid.

I then verified the directory name was correct = C:\Program Files (x86)\COMODO\COMODO BackUp and that the CBU.exe file did exist. . . so what now?

You need to put that line in quotes for the proper test.

Please try the following command:
“C:\Program Files (x86)\COMODO\COMODO BackUp\CBU.exe” /RunSp
ecificScheduleItem 63255749225

Thanks

I’ve been working too many hours, I should have remembered where the quotes belonged. . . .
Your revised command string does successfully start the Backup program.

I tested this on Wiindows-7 and when I ran the command as you requested, the Windows ‘User Account Control’ intercepted, requesting “Do you want to allow the following program to make changes to this computer? YES or no” - hence, when this run’s as a scheduled task we need the Backup to continue without such a prompt.

Please advise how we can deploy this solution, i.e. will you issue a software update or can we manually edit a file for now?

Within Windows Task Scheduler, I selected the CBU taskID 63??? ? job entry set by Comodo Backup and on the Actions tab, I Edit the command script, simply placing quotes at each end i.e. “C:\Program Files (x86)\COMODO\COMODO BackUp\CBU.exe” and saved the job.
I suspect this work arround may work, but every time I EDIT the Script the quotes are removed, once I add them again, they are displayed in the summary screen. Odd. . .

Please make sure that the “Run with highest privileges” checkbox is checked, like in the attachment.
Go to conditions TAB, and make sure there are no conditions that do not allow the task to run.
Then try to run it again, manually.
Does the Windows 'User Account Control ask for your permission again?

Thanks

[attachment deleted by admin]