Scheduled backup not working, manually works


When I do a manuall backup (selecting ‘run backup now’) the backup is created without any problems (as far as I can see now). When the scheduled time comes, the backup isn’t created and I get a mail saying that the sources can not be found.

The manual run

Backup "Dagelijkse Backup" completed successfully. Compared 16417 files, 20110 folders. Copied 16402 files.

The scheduled run

Error - Backup "Dagelijkse Backup" completed with error. Compared 0 files, 0 folders. Copied 0 files. Error - Source folder does not exist ! Error - Source folder does not exist !

The source folder is //server/administratie and //server/mijndocumenten

I am having the same exact problem. any help regarding this would be greatly appreciated!!

the service running under localsystems account, which have no access to network. Run the comodo service as an administrator.



I changed the service to run as administrator, but still no go. Any other ideas? (:SAD)


Please update your Backup or download new version from

Try to login as administrator or any user with administrator rights.
If the problem will occur again, please attach the last part of CmdBkpSvc.log since failed Backup event, then perform Backup operation manually, and attach part of CmdBkpSvc.log once more.

I know I am only a Newbie, and maybe this isn’t the right place to put this reply… please correct me if I am in error.

I posted a new topic just below this one before this one was posted. It is titled “No start with Windows” choice in Backup… I have been having the same issue, but with the synchronized backup, not the scheduled backup.

Updating to this new version seems to only start the one part of the backup service (CmdBkSvc.exe).
With just that service running, my automatic sync does not take place. If I manually open Backup, then minimize it to the tooltray without exiting it, then the CmdBackUp.exe service/process starts and auto syncronization works perfectly. As the sync is an automatic procedure as would be scheduled backup (I would think?), maybe scheduled backup ALSO needs the CmdBackUp.exe process started manually each time when Windows starts in order to work as it should. (The earlier version of Backup had a “Start with Windows” choice. The updated version does not…)

I am having the same problem. I tried every configuration possible. CmdBksSvc.exe starts with windows everytime, but the scheduled scans will NOT start unless I physically open the program. I tried putting Comodo Backup into the Startup folder which helped. But now it opens on the desktop and stays open even after the backup job is done and it will not close until I manually close it.


I’m having pretty much the same problem. I installed Comodo Backup on a couple of windows XP SP2 systems which have never had any Comodo software on them before. Manual backup works fine, Manually scheduled incremental backup, rebacks up a few unchanged files, but mostly it only backs up changed ones.
BUT the scheduled backup (to start on a particular day of the week at a particular time) doesn’t start - with or without Comodo Backup running - minimized or otherwise. Judging by the number of people who’ve viewed this thread (1,296), quite a lot of us are experiencing some difficulty getting this to work!!

Hello Shamus9, jminnie, and TomC

I have never had a problem with scheduled backups running whether incremental, synchronized, or zipped, or every other way I have tried it. Even the email notify works well. This goes for version as well as for which I have just installed this week and have not tested it more than a few day.

As well as ComodoBackupService having to be a running service and on automatic, the process CmdBkSvc must be running and CmdBkStart must be in the registry startup Machine Run as CB Active User. If these are all in place and it still will not run a schedule then I would suggest possibly a corrupt install or something conflicting with the service either on installation or scheduling.

Let me know if I can be of any more help to you.


Hi JJasper,

I am not at the machine with Comodo Backup on it, but I spent all day playing with it again. There is only one service running (CmdBksSvc.exe), but nothing else. If I open the program manually more services open and all works well for the first time only. I have confirmed this on 2 computers. I have tried un-installing & re-installing with the same results. I have tried un-installing, cleaning any left over files & the registry and re-installing, again with the same results. The program performs the backup when the program is opened manually but it does not perform ANY scheduled backups. I have disabled all software running (thinking there may be a conflict) but there wasn’t. I have also tried changing every setting in the program (countless times).

I am at a complete loss. ???

Well, same here, latest version, I’m using the XP with adminstrator rights, manual backup works, scheduled not. From CmdBkpSvc.log I can only see that last line is Service started from past week so CmdBksSvc.exe is running.

Changed also the service to run as me, same problem.

Does anybody knows the fix?

Hey ksuuk,

It’s working at me, even when my user isn’t logged on.

Ok, let’s try to move on :). Check the attached picture and what i painted with red square. Do you see any differences between this one and your setting?


[attachment deleted by admin]

Yes, all same. But still nothing happends, no backup.
Backup mode is simple copy, schedule is set to tun every day, compression enabled with store full patch and protect with password, file create mode full backup.

Changed back service run as local user, and I can see from logs Error - Cannot create folder K:\backup, and K is a network drive and backup is there a folder and also the create folder is previously selected.

Changed back to run as local user, same error. So something is wrong with network part. But what?

Any more hint?

Can you please create a batch file which should run BEFORE the job:

  1. open notepad
  2. type in:
    net use K: \\d$
    “net use” is the command and the syntax.
    “K:” this is to check if K: exists for the user or not.
    \numbers - change here to the remote IP address
    d$ - type here the share name (eg. MyShare, c$, admin$, SOFTWARE, etc.)
  3. save it as runbefore.bat (no double-extension so use .bat and select All files from drop-down menu)
  4. set up this file to run before the job.

Do you work with a domain or workgroup network? In any normal cases you shouldn’t be able to write to a remote share unless you set up the necessery rights. So if needed, type in “/user:” and password part to the batch file to access the another machine (eg.

net use k: \\\d$ /user:\ksuuk yourpasswordhere

, you may want to use /savecred). Microsoft net use document.

Ok, but this will try to mount existing share, and this is not allowed - “The local device name is already in use” and I’m getting the same error as before - “Cannot create folder K:\backup” And I’m not the domain user, but I must login into share as domainname\username.

What is wrong with this software? It wont even run the scheduled jobs when the GUI is open? Is there any possibility to use some debug mode, to get more info?

I set up Comodo Backup to backup a share on a server to my local pc then another backup to be burned to a DVD and they both work “now”.

What I found out was that if I used the drive letter it would not back up. I had to use the actual server name and the share name and then either the folder or the file that I wanted to backup . I have been using this setup for a month without any problems. I can back up to a USB drive from the server but I have not been able to put the files from the USB drive onto a DVD using another scheduled backup task. What I had to do there was put the files on the C: drive on the first backup then the second backup put them on a DVD. So far so good. Everything works like clockwork now. Email notification works too.

Before that, I found another problem that Comodo firewall was asking to OK the backup service to run and, of course, I wasn’t there so it wasn’t allowed by default I guess. I got that fixed and that problem was solved.

Just some things to try.


What i was thinking about:
IF you are not logged in, the system won’t see a mapped network drive’s letter, which is correct. But if you map it with your rights you must have rights to source/target PCs. I think the problem is that CB can’t handle these as the same process (eg. to run that batch file, so you got K: drive and then later to access it). I recommended to use the save rights switch so that may solve the access problem (any envent viewer entry at security? try to set up logging at gpedit.msc).
I think CB can’t recognise user settings, like mounted devices. So jasper2408’s suggestion is a must, you may want to try to work with network paths so it won’t depend on personal user settings.

Tried to use \server.domain\folder\backup - same problem, manual backup ok, scheduled not, same error Cannot create folder…

Damn. I need to use some backup software, with password protected and exclude files option, but can’t find any good and working freeware.

SyncBack, i’ve tested this one and works well (got freeware version, too). Maybe you should open a ticket with your problem, as i can’t reproduce the problem but the programemrs might got ideas how to do so.


We had exactly the same problem with a machine running Win XP Pro. I raised a ticket with Comodo but was referred back to this forum! In any event, I have managed to fathom out what the problem appears to be (at least in our case) : It seems as though the backup service is not running with administrator privileges, even though logged on with an admin account, when the backups are set to use the local account.

What I did to get it to work was the following :

  1. Make sure that each job’s backup type is set to run as a “service backup”.
  2. In your Process List (press Ctrl-Alt-Del to bring up Task Manager), ensure that CmdBkSvc.exe is running.
  3. Go to Control Panel → Administrative Tools - > Services → Double-click on ComodoBackupServices and under the Log On tab change it from Local System Account to “This Account”. Fill in the account as .\accountname (where “accountname” = your Admin account name). Under the password field fill in your password and confirm.
  4. Apply and Ok and then test by changing the backup time on one of your jobs to one minute hence.

I have left the Comodo Backup GUI running since I find it useful to quickly make changes. I have not yet run it without the GUI loaded. However, the manual does say that only the service needs to be loaded so am sure it will run in that event.

Hope it works for you. Good luck.