Scheduled backup - doesn't

I’ve just installed Comodo Backup 2.2.127000.12 on Windows Server 2008.

I’ve run a test backup (to a USB 2.0 removable hard drive - 1.5TB) successfully as a “backup now” and have set up a scheduled backup to run at 1:00am every day. It’s a files and directories backup to backup financial data. Unfortunately, checking the Comodo history this morning, the scheduled backup hasn’t run. The job is there as a scheduled job, but the status is “Never” (i.e. it’s never run).

I’ve installed Comodo as an admin user and set up the scheduled job as an admin user, so why isn’t the schedued job running?



What “Run mode” have you selected?
There are 5 options (Normal, Auto-click Finish, Auto close GUI after backup, Silent run and Service Run)
If you selected any except “Service Run” and you were logged off while schedule was supposed to run, the schedule will not run because user is not logged in.
If you select “Service Run” then it will run as scheduled even if user is logged-off.


I did select “Service Run”. Is there anything in Windows 2008 Server that I need to turn on? Task Scheduler is running. I can run the backup “on demand”, but I can’t schedule it. Seems like it doesn’t work on Server 2008. Looks like I may have to buy/try a different backup. Windows 2008 built-in backup is not suitable as it does not have the feature to back up selected files and folders.


Was your computer shut down entirely or were you just logged off?
Also please tell us what is the edition of the Windows Server 2008 you are using and whether it’s a 32bit/64bit operating system.

You can also run the “Diagnose” function in Settings tab to make sure the application is installed correctly. Then go to the install location and check for the “Diagnose Report” file. Please attach this file to your next post.

Thank you.


The computer is on 24/7. No one was logged on at 1:00am, when the backup was scheduled to run. The system is a Dell twin XEON server, Windows Server 2008 Standard, SP1. I access it via Remote Desktop and have administrator privileges. I installed Comodo backup and created the scheduled backup under my (admin) account. I also went into properties of CBU.exe and checked “Run as administrator”.

The diagnostic report is as follows.

Thanks for your help.

Checking if restart is needed…
No restart needed… OK!
Verifying your windows version…
Windows 2008 Server
Windows version check OK!
Checking Synchronization service…
Synchronization service OK!
Checking CBU.exe integrity…
CBU.exe is OK!
Checking SynchronizationService.exe integrity…
SynchronizationService.exe is OK!
Checking ComodoCrashReport.exe integrity…
ComodoCrashReport.exe is OK!
Checking ShellExtension.dll integrity…
ShellExtension.dll is OK!
Checking cbufs.sys integrity…
cbufs.sys is ok!
Checking BDisk.sys integrity…
BDisk.sys is ok
Checking cbunat.exe integrity…
cbunat.exe is OK!
Checking if BDisk.sys is working properly…
BDisk.sys is working properly!
Checking if cbufs.sys is working properly…
cbufs.sys is working properly!
Checking windows task scheduler functionality…
Windows task scheduler is working OK!
Diagnostics ran successfully!

I went in to Windows Task Scheduler and did find the Comodo Backup task scheduled to run at 1:00 am every day. But in task scheduler, the box “Run only when user logged on” was selected. I selected “Run whether user logged on or not”. We’ll see what happens tonight.

So selecting “Run as service” has no effect on the “Run when user logged on” option in task scheduler. There should be an option in Comodo to select whether the scheduled job is to be run whether the user is logged on or not.


Please let us know if the scheduled task runs.
Because it was a “service run” backup it was not supposed to appear in Windows Task Scheduler unless it was a “log on” or “user idle” schedule.

The backup ran OK. I haven’t tested the restore yet nor done a compare between the original and backup, which is my next project. It looks like the “run as service” option has no effect. The backup job was scheduled in task scheduler and marked as “run only when user logged on”.

In Comodo Backup, the options are:
Scheduled Backup - checked
Daily 1:00:00 am
If schedule is missed - do nothing
Run Mode - service run

The Windows Task Scheduler shows:
Task Name - CBU taskID 63250041021 4 description Comodo backup scheduler
Run only when user is logged on - selected
Run with highest privileges - selected
Action - Start a program
Program - C:\Program Files\COMODO\COMODO BackUp\CBU.exe
Arguements - /RunSpecificScheduleItem 63250041021

When I changed the option to “run whether user is logged in or not” the task ran at the correct time. No one was logged in to the server at the time.

So it looks like the “service run” option doesn’t work.


It looks like there is a problem with “service mode” backups.
We will fix it in the next release.