Scanning Window Not Properly Aligned When Threats are Found [M20]1[v6]

When threats are detected the antivirus scanning window does not readjust itself. This means that some of the information is now pushed past the bottom of the screen.


  1. What you did:
    I downloaded some malware and put it in a zip file. I then unzipped the password protected folder and immediately began scanning it. Some files were found by the real-time scanner and some by the on-demand scanner. However, I’ve also seen this behavior for the scan window when the on-demand scanner did not first detect anything.
  2. What actually happened or you actually saw:
    What happened was that as soon as the first threat was found the scanner widened itself vertically to show the additional information. However, by doing this the bottom part of the scan window was pushed below the taskbar.
  3. What you expected to happen or see:
    I expected the scanning window to recognize my screen resolution and adjust itself so that the entire scan window can be seen, regardless of whether it found a threat or not.
  4. How you tried to fix it & what happened:
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?:
  6. Details & exact version of any software (except CIS) involved (with download link unless malware):
  7. Whether you can make the problem happen again, and if so precise steps to make it happen:
    Just run a scan, on-demand, quick, or full, in which the scanner will detect something dangerous. Then pay attention to how the scanning window adjusts itself.
  8. Any other information (eg your guess regarding the cause, with reasons):
    I’m not sure what causes this, but it may be due to the scanning window not properly adjusting itself to the screen resolution.
    B. FILES APPENDED. (Please zip unless screenshots).:
  9. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues):
  10. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active Process List. If accessible, required for all issues::
  11. Screenshots illustrating the bug:
  12. Screenshots of related CIS event logs:
    Attached, both the scan started and most of the results of the scan.
  13. A CIS config report or file:
  14. Crash or freeze dump file:
  15. Screenshot of More~About page. Can be used instead of typed product and AV database version:
    Information provided below.


  1. CIS version, AV database version & configuration:
    Comodo Internet Security Version 6.0.260739.2674
    Database 14614
  2. a) Have you updated (without uninstall) from a previous version of CIS:
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS:
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
    No, it is default.
  5. Defense+, Sandbox, Firewall & AV security levels:
  6. OS version, service pack, number of bits, UAC setting, & account type:
    Windows 7 x64 (Service Pack 1)
  7. Other security and utility software currently installed:
    Just Comodo System Utilities and CCleaner.
  8. Other security software previously installed at any time since Windows was last installed:
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]:
    Not a virtual machine.

[attachment deleted by admin]

This bug still exists in version 6.0.264710.2708. Please feel free to contact me via PM if you have any questions or require additional information.


This is still not fixed with version 6.1.275152.2801.

Updated in tracker, thanks

This is still not fixed with CIS version 6.1.276867.2813.

Tracker updated, thanks

This is still not fixed with CIS version 6.2.282872.2847.

I have received feedback from the devs that apparently this is by design.

Thus, I will move this to Resolved.