Scanner will no longer scan

Since installing Comodo Firewall, my Lexmark x5470 All-In-One, will no longer scan. It is also my printer, but the printer works fine. It worked before I installed Comodo firewall, and it works if I uninstall Comodo firewall - However if I uninstall Comodo firewall, by internet shuts down, and I experience crashes and “blue screens of death”. Once reinstalled, these crashes and blue screens disappear, and I can reconnect to the internet.

At this point, I have 2 choices -

  1. Permanently uninstall Comodo
    Unfortunately, when I tried this last time, the firewall caused crashes, blue-screens, and loss of internet.

  2. Stop using my scanner
    This is not an option, as I need the scanner, which is why I bought the All in one.

Can someone please help me to get the scanner working?

The Scanner/Printer is directly connected to my computer.
I am using Windows Vista 32 Home Premium
The Printer works
The scanner worked before I installed Comodo.
If I uninstall Comodo, the scanner works.
I have tried putting the firewall in learning mode.
I disabled the Defense+ as I have these functions in other programs.
If I disable Comodo firewall, the scanner will still not work.
I have the most recent drivers for the scanner (3 days old)
I do not have a virus/trojan on my system, I checked with Avast! and Defense+
Diagnostics for the firewall, tell me it is running fine
I have allowed Lexmark
I have allowed all of the scan and printing processes
I exported my settings, click here to download.
I allow autoupdates for the firewall
The firewall version is

Further info -

Since it appears you have tried everthing else, just a suggestion try CPF3 Defence+ in Paraniod Mode you might have to delete the rules you already have made, but just try Paranoid Mode first.
I have not used my scanner since I install CIS connected the USB cable then had about 10-15 alerts including those for the toolbox.
P.S. Just a thought can you connect your printer/scanner any other way to your computer different cable?

Ok, Since I had D+ disabled, I re-enabled.
I kept clicking for 10 minutes, to allow it to reboot.
On reboot, I clicked another 10 minutes, until I just allowed everything as an installed, trusted, or system (then later changed these to reflect what they truly were)
I also tried unplugging and replugging in the usb, while in paranoid mode.

I tried to scan, same thing - it either freezes, or will not allow me to scan/preview.

Now D+ is once again disabled (with a reboot), however this time I made sure to go in and unclick everything which could be deselected to make sure that it wouldn’t watch this or that.

Nothing. Won’t scan, won’t preview, but the printer does print.

I have searched for solutions with the keyword “lexmark”, and see about 10 other problems all with version 3, that remain unresolved. The one thing that does show as fixed, I tried, but it did not work for me.

Also spoolsv.exe was an allowed process.

I was running Process Explorer, while I tried to do a scan, and did notice one thing. The preview/scan program was prematurely shut down. I noticed after rebooting and once again disabling D+. I did not have a chance to register the name not take a screen shot. Further attempts to get this to open have failed.

Shutting down the Comodo firewall does not allow me to use the scanner.

Any other ideas?

Also… assuming that it is not something that can be resolved, how do I completely remove version 3.x from my system, without causing my system to crash, lose internet connectivity, and give me “blue screens of death”? I read up on this, but there does not seem to be a clear explanation for version 3.x on Vista. Previous uninstalls have caused the aforementioned problems. I know the problems are Comodo related, as I did not have these problems before I installed Comodo.

I am very sorry you had to go through all that clicking for nothing.
Have you tried for the scanner link Right Click/ Run as a Adminstrator?

I run everything as an admin, and UAC is turned off.

For anyone else who reads this, then I suggest not using Comodo firewall, if you have a Lexmark printer. There is no known solution to this issue. It does not have to do with Defense+ but rather with the firewall itself. If you search for Lexmark on the forums, you will see others having issues with no clear instructions on how to fix the problems.

To uninstall Comodo 3.x from Vista follow these steps.
[]Right click the Comodo icon in the task bar, and tell it to exit.
]Ignore the warnings about no firewall
[]From the start menu, select “run”
]Type in msconfig
[]In services, deselect Comodo Firewall (and anything else by Comodo) - We do not want it to run on startup
[]When you login, press ctrl-alt-delete, and goto the Task Manager. Make sure nothing is loaded by Comodo.
]Goto Control Panel → Programs and Features
[]Uninstall Comodo Firewall
[]From the start menu, select “run”
]Type in “regedit”
[]Goto File → Export
]Type comodo_A.reg and save to C:\ (this is so you have a back up which is easily accessible)
[]Do a search (ctrl-F) for “Comodo” anytime anything comes up with Comodo, hit the delete key, and enter.

Congrats you are now Comodo Free. If you want to reinstall Comodo or their Defense+, now your system is clean to do it with. Comodo firewall is rated the highest of all firewalls by independent testing for safety for the user. However, there are many of alternatives to Comodo firewall (though not rated as well). For an alternative to the AV, try Avast! (rated best AV by independent testing centers). For an alternative to Defense+ try Spybot Search & Destroy (Spybot S&D) with TeaTimer, which is included in Spybot S&D to protect the registry keys.

For those who tried to help me, thank you for your help, but I can now see there must be an alternative, for me and my Lexmark.