Scan won't complete

Hi- version 3.0.24.368
I hadn’t tried to scan my system since the install run but due to Aviar AV issues, have been trying to re-scan for a couple of days. All’s well for about 15-17 minutes, then the scan just stops? No report, not really frozen, just sitting there. I’ve tried 3X’s last night, and each stopped. Any ideas on getting this straight? Thanks.

Post a screen shot. I am sure its complete if you look on top. Others have misread it.

This time it ran 20 minutes . . . here’s that shot. I waited 10 minutes after the scan stopped.

[attachment deleted by admin]

Screen shot is too small but if the magnifying glass around the pc icon has stopped then its done. The scanner in Comodo is still new.

Sorry about the small shot. Of course the magnifier has stopped, as I wouldn’t have posted were the scan still active . . . also the “time” duration meter being stopped indicated to me that the scan was/is done.
It just seems there should be something in the empty results box noting the scan is complete. Also, it seems to me that after the initial scan on install, Defense and security level changed itself from safe to clean?
Am I wrong about this last bit?
I resized that screen shot for ya. it’s a bit fuzzy, but hopefully better?
Much thanks for your helping me.

[attachment deleted by admin]

From what I can read of the pathname, C:_vbs.schclass, I’m wondering what this file actually is. Very few things these days drop themselves into the root directory of the C:\ drive.

Can you post a screenshot of the file properties “general” tab? That’s going to Windows Explorer, going to the root directory, and then right click on the file name, and select “properties”. It should open up to the general tab automatically.

I will attempt to post this files props. You should know thought that each scan stops on a different file, although this one we’re discussing here I do recall seeing on one of the incomplete scans yesterday.
I hope this is the right props info. Not much there.

[attachment deleted by admin]

A real quick google leads me to think this might be some kind language parser schema, in which case it could have an infinite recursion if any kind of analyzer actually tries it as code. Or it could be something else, and potentially unwanted. Just to be on the safe side, I’ll suggest submitting this C:_vbs.schclass file to http://www.virustotal.com/ or to http://virusscan.jotti.org/

Yeah, it was clean on Vtotal. Here’s a few lines I don’t get, but they might say something to you. Thanks. So is it looking like this is stopping the scan. I’ll run another right now and see what file it stops on this time? Post that one? THanks (:KWL)

OK . . . well, it did stop on that file, but 15:09 in and after scanning 87,130 flies. The earlier screen read 20:17 and scanned 87,097 files. Hmmm. What’s that mean? Lemme run it again. BRB. Ok. 3rd scan. Stopped on same file, 16:08/87139?
I’m basically sitting here on two forums, not doing much on this pc. Is that normal for the file to be moving all over the place (based on scan times?)
Anyway, here’s that other data from virtotal.
File size: 15943 bytes
MD5…: 8f48df21319c00cca86f4af5e3ebc98a
SHA1…: fdebe93e5c27a4b44e40484e1336928d9f42da39
SHA256: 8aa9e975df0c188f044eeb86e4a0fcae594501fa45078513d87c346550f5a1c1
SHA512: 3b4c75971ae9265e30a3a67d98d225f10ed31c48ec125310bc2b6aa0e423daf3
5e825b50ec18815494fee6bfd24d06683a63639e98f29ab84b03d5eebd56322f

The MD5 and SHA1 checksums don’t turn up anything. That doesn’t surprise me.

The scanner available in CFP doesn’t have a exclude facility that I know of. That’s the only alternative that I can think of right now. That means using one of the other virus scanners (avast, avira, avg, or paid product, or one of the on-line scanners like that from kaspersky.com), and putting at least this c:_vbs.schclass file on the “exclude from scanning” list if the scanner still can’t handle it.

I’ll also suggest submitting the file to Comodo. If it wedges the Comodo scanner, then the scanner needs some work, and having a demonstratable wedge is a good incentive. In CFP, click Miscellaneous → Submit Suspicious Files, then Add, and navigate to the file and select the file.

If there are other files that the CFP scanner is stopping on, I’ll suggest the same process: virustotal, and submit to Comodo.

With all views enabled, the add file box from Comodo won’t show the additional files. Under types, it has executable, which I’ve changed to no avail. This is a SCHCLASS file, whatever that means? There doesn’t seem to be a way I can find to make it show in the Comodo pick-a-file box? Shows fine elsewhere. Just can’t submit at this point.

That shows how often I try to submit files. Evidently, submitting a file from CFP is expected to be only an executable. Which makes sense for CFP and Defense+, which concern themselves with executables. But scanners go thru pretty much everything. So evidently the scanner facility in CFP is not that well integrated just yet.

The Comodo antivirus (CAV) has a submit function. That, I’m sure, would work. But would that file wedge the CAV scanner? Don’t know, but if it doesn’t then why submit it?

If nothing else, I think you’ve found a bug in CFP. I’ll invite you to submit a bug report in the forum https://forums.comodo.com/bug_reports-b106.0/ that you cannot submit files found by the CFP scanner that aren’t executables.

Otherwise, it looks like you’ll have to use a regular virus scanner, either as an installed product or one of the on-line versions.

So I just want to report that my scanner keeps stopping while scanning this file and I can’t submit it to Comodo because interface won’t accept SCHCLASS file extensions?
You do see that it’s been cleared thru virus total, right?
I really appreciate your assistance in this. (:KWL)

So I just want to report that my scanner keeps stopping while scanning this file and I can't submit it to Comodo because interface won't accept SCHCLASS file extensions?

Yup. Since it isn’t an executable, you can’t submit it. Although you hit a file with a schclass file extension, you could have hit a live virus in a pdf file or a swf file, and you wouldn’t be able to submit those either. PDF and Flash files are current active virus vectors, but they’re not executables either, according to the CFP submit menus.

You do see that it's been cleared thru virus total, right?

Yup, got that. That’s why I’m still my normal calm self. Otherwise I’d be having you run malware scans over anything and everything. :smiley:

Just for cross reference, there is a bug report entered at https://forums.comodo.com/bug_reports/cannot_submit_files-t25602.0.html

Thanks, MrFishy!