Scan Settings and description not clear / wrong information [M176]

The definition of a Quick scan [Mod edit: on it’s button] is- “Scans commonly infected files and Memory”, although if you check [Mod edit: the profile] it only scans Commonly Infected Files. A Full scans definition [Mod edit: on it’s button] is- “Scans all Files and Folder on the computer”, it does no specify Memory although Memory is in the[Mod edit: profile] settings.

A. THE BUG/ISSUE:

  1. What you did: The quick scan says it scans memory but it says it does not, and full scan scans memory but doesn say it does.
  2. What actually happened or you actually saw: Same as above.
  3. What you expected to happen or see: The quick scan and full scan Both to scan memory, and both to say they scan memory.
  4. How you tried to fix it & what happened: N/A
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?: Yes, did nothing
  6. Details & exact version of any software (except CIS) involved (with download link unless malware): N/A
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Click Scan in the task bar. The definitions are misleading, If you edit these under Advanced settings you can see the quick scan does not scan memory and full scan does, but both say otherwise.
  8. Any other information (eg your guess regarding the cause, with reasons): N/A

B. FILES APPENDED. (Please zip unless screenshots).:
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues): In Attachments.

  1. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active Process List. If accessible, required for all issues:: 2 Screenshots in Attachments.
  2. Screenshots illustrating the bug: Screenshot in Attachment.
  3. Screenshots of related CIS event logs: N/A
  4. A CIS config report or file: Default- Turned Heuristics to Medium and turn on cloud scanning in Scans.
  5. Crash or freeze dump file: N/A
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version: In Attachments.

C. YOUR SETUP:

  1. CIS version, AV database version & configuration: In Attachments
  2. a) Have you updated (without uninstall) from a previous version of CIS: No, this is a fresh install of windows, no AV’s have been installed.
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: N/A
  3. a) Have you imported a config from a previous version of CIS: N/A
    b) if so, have U tried a standard config (without losing settings - if not please do)?: N/A
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security levels: Default/ Internet Security
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 64bit NO SP1, UAC Off, Admin.
  7. Other security and utility software currently installed: Malwarebytes scanner, (Realtime off)
  8. Other security software previously installed at any time since Windows was last installed: Malwarebytes
  9. Virtual machine used (Please do NOT use Virtual box): N/A

[attachment deleted by admin]

Thanks very much for doing this, I will process it later

Best wishes

Mouse

These settings will quickly scan configured by default and do not change. Need to do a custom scan profile and specify where in memory.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

The Fullscan now shows that it scans memory when editing the profile. However the Quickscan still does not have memory in the profile, even though its stated that it ‘Scans commonly infected files and Memory’

Only half the bug is fixed.

Tracker updated

Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Can you please check and see if this is fixed with the newest version (6.3.294583.2937)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Hopefully these 2 screenshots better explain the the issue.

http://puu.sh/4ECSv.png

http://puu.sh/4ECTr.png

I would say that this minor issues has not been fixed, it is not a serious issue but the descriptions of the scans to some people could get some confused.

Thank you for checking this. I have updated the tracker.

Also, as I see that this is a GUI issue, I will move it to that section of the bug reporting forum.

Thanks.

Can you please check and see if this is fixed with the newest version (7.0.313494.4115)? Please respond to this topic letting us know whether it is fixed or if you are still experiencing the problem.

Thank you.

PM sent.

Actually, upon further inspection I see that the devs have recategorized this as an enhancement. I will therefore move this to the Verified Wish Board. Please still let me know if this has been implemented for CIS version 7.0.313494.4115.

No this has not yet been fixed. Quick scan still says in its description it scans memory yet in the scan options it only says Commonly infected files, and for Full scan it says it scans memory in the options yet its description doesn’t state it does.

Thanks for checking this. I have updated the tracker.