Scan during installation is extremly slow


I am just installing the Comodo Firewall Pro on my other PC (Laptop with Pentium M 1.4). ZA has been used on this machine before but was deinstalled.
My Problem: I chose to run the System Scan during the installation, and it is now running for more than 17 hours. During this, a “Trojan.Win32.Patched.m(ID = 0x4d69a)” was found in “C:\Windows$NtServicePackUninstall$\winlogon.exe”. I’m sure this is a false alarm, but I will check it later using different Online-Scanner.
But how is it possible that the scan takes so much time? A few hours testing every file would be possible, I have this with other AV too, but 17 hours for a 60GB-HD, and it is still not finished? The Task-Manager shows about 70-80 % CPU-load for the cfpconfig.exe, about 20-25% for csrss.exe and sometimes a few % for other tasks like my AVG.

€dit: CPU-Load doesn’t change when I pause the scan, which makes it even more suspicious to me ???

I’m not a Comodo expert however I have seen this in the past with Comodo FireWall Pro. My recollection is that I stopped the scan and then un-installed, cleaned the registry, and then reinstalled to solve the problem. I suppose it is possible that there is some sort of conflict with AVG. You might want to disable it and see if the scan works.

The scan takes about 10 minutes on my loaded laptop scanning a nearly full 60G partition.
17 hours - something is wrong.

You might want to wait though and download the new beta Comodo Internet Security Suite which includes AntiVirus and Firewall and Defense+. It is supposed to be released for public beta today. Check back later on the forum under CIS -

Good Luck and best regards
Russ (V)

I had a similar problem. My scan took about 1 hour, one false positive (?) was found, but when the scan had reached the - presumably - last file on my HD it just kept on going. Symptoms were exactly the same for me, including cfpconfig.exe using roughly 70% CPU.

I’m not an expert either, but I am absolutely sure 17 hours is waay too long. I solved the problem by shutting down CFP, manually terminating cfpconfig.exe (from the task manager) and then starting the firewall again. After that it worked just like normal.

I won’t say for sure it’s a bug. But I think it is. Anyway, I’m waiting for CIS to come out, so I haven’t tried to fix the problem…

same here…seems to lag up between c:/windows/software distrib… /windows/system32 Have tried to install 3 times and each time froze up…one time overnight…and manages to fry my internet connection in the process…just tried a fresh format and am considering installing an earlier build. Anyone know what’s going on?

Is this supposed to convince me to d/l CIS?

Might be something related to the last signature updates, I had problems with the scanner:


Just ran the install under SP2 (opposed to SP3) and worked like a charm. Now I can go be happy again…Still not sure of the exact issue…or whether it’s fixed for that matter…

The slowness is fixed for me in the last AV sig update. Can y’all confirm now?



If we don’t receive word from Pcln3 within one year from now, assume issue is resolved and close thread.

Solved it - more or less

I stopped the scan after ~ 18h and closed the window. Unfortunately, the setup didn’t continue, so I rebooted after some time. After the restart, the PC couldn’t get an IP from my router, so obviously a firewall was blocking, but no item for the CFP was visible, it’s nowhere in the Program-Menu or the Software-list in the system >:(
After manually starting the program, running the diagnostic and rebooting, the firewall works, and the scan now takes about one hour, slowed down by the hard-disk speed and producing 3 other false positives.
But I won’t be able to uninstall it properly missing the uninstall-routine, so I decided not to use this program on further PC’s.

The false positives is another issue that recently spawned.

As for uninstalling CFP, you can download the batch script. It was created by forum members from this thread.

Thx for the link^^ :wink: