Every time I plug my SanDisk in Defense pops up asking for permission every time for the app called launch to run(I run Defense is safe mode). This last time instead of click remember as an installer I chose external app, that is when my trouble began. I could not reboot, it said I did not have permission with no other error message, lost all in the task bar also and Comodo would not open. I had to shut down with power switch and go to safe mode. lucky for me restore from previous date cured my problem Any idea why Comodo blocked my administrative account?

Hi Bucko

Without knowing what “launch” is (full name & location) & the actual alert that CFP displayed, I cannot really say. I can wildly speculate that is was something to do with SanDisk’s IO drivers being blocked. But, “external app”?.. I’m not exactly sure what Predefined Policy that is (I don’t have it - possible due to upgrades). So, I need more details I’m afraid. Knowing your OS might help as well.

Sorry I forgot to mention the details. My op system is XP Pro and the app is Launch.exe ( a menu which you can select different apps on your SanDisk). My Comodo version is 30.25.378. It seems Comodo can never remember what Launch.exe is and is always asking. I did tell you wrong, I chose Isolated mode (sorry). I did manage to cure asking every time popup, dummy me. I switched to installation mode and that cured that. Guess I still don’t know why it shut me out of the computer but at least things are back to normal. Thanks for you reply and time.

What is the disk location of Launch.exe? Any chance that you can post a screen shot of one the CFP alerts for Launch.exe? Have you tried telling CFP that Launch.exe is a Trusted Application?

I’m not sure why it shut you out either, but I suspect that applying Isolated Application to something that was, in effect, a system component might have fairly grim results.

I think this could be a case of Defence+ not considering any executable safe from a non fixed drive(usb stick) in clean pc mode or above.

I would say you are correct on Defense considering it was unsafe. As for the alerts I don’t get it now so I can’t give you a screen shot, sorry. Using Defense in installation mode when opening Launch.exe cured the pop up. But to answer kail the Launch.exe is located on the SanDisk. Thanks for your help.