Sandboxie not working after Upgrade to CIS6

Hello All. This might have been posted before but after a lot of goggling and searching through these forums, i’m not able to find a solution. I use the free sandboxie program to sandbox my web browsers. It was working fine with the older version of comodo. However, the moment I downloaded the new version of comodo CIS 6, I’m unable to get sandboxie to connect to the internet. I click on the browser and it just hangs and doesn’t get any traffic. If I uninstall comodo or exit out of comodo then sandboxie is fine.

I tried setting it as a trusted application. I’ve tried with Behavior block off and On. I’ve defined it as part of the exceptions for behavior block.

Can anyone tell me how I can get sandboxie to work with the new comodo? Thanks.

UPDATE: It appears to be only happening for CHROME…firefox seems to work.
update2: It appears to also not work for comodo dragon. so all chromium based browses do not work.
update3: so firefox…works until you try to view flash videos (just clicking on youtube causes it to freeze). This is not happening outside of sandboxie. normal firefox can view youtube and other videos. also i don’t see any problem with comodo’s sandbox. everything appears to be working fine. so it is something with sandboxie and the new comodo.