Sandboxed Opera Cannot Connect to Built-in VPN

When I launch Opera through the Comodo Cistray, The VPN feature in Opera stays on the message “Connecting…”. No Internet access is possible. If I disable the VPN, Internet access resumes. I can enable the VPN in an Opera instance that I launch through the Windows Start menu.

I am running CIS Premium on Windows 10 version 1607, build 14393.1770. Opera is 64-bit version 48.0.2685.52.

Please assist.

Sandboxed applications are blocked from accessing the loopback interface to prevent sandbox escape and data leakage.

Hi futuretech,

Thank you for your reply. Please explain how the Opera VPN feature relates to the loopback interface?

I should mention that the VPN feature worked fine in the sandbox when it was first released. I had been using it for several months. It is only in the last few months (releases?) that it stopped connecting.

It works for me, though it had an issue the first time I tried enabling the VPN while Opera was running sandboxed. Once I enabled VPN outside sandbox, then run inside sandbox I was able to connect to VPN.

Thanks for testing it on your system futuretech. I tried flipping the switch on/off between the sandboxed and non-sandboxed versions, but it didn’t help. Hopefully, someone from Comodo can chime in with some guidance.

I should also mention that I did previously try uninstalling and reinstalling Opera, but it did not help.

Maybe wait until next stable release? I have been using the beta when I tried so maybe it is a bug that is fixed in the newer version?

The next stable release of Opera? I have been through several releases now with this issue. I just didn’t have the time to seek help until now.

No, stable release of CIS. I had no issue on v6382 beta 3 and now on v6392 beta.

Oh, OK. Will do. But it still would be nice if someone from Comodo would investigate this. Surely, I am not the only one experiencing this issue. It’s also rather ironic that a security feature would make browsing less secure.

Had some issues with sandboxed apps internet connection too. But they were caused by “No popup alerts>Block requests” Firewall option. Fixed by changing this to show alerts, now it prompts to allow sandboxed apps go online. Maybe you could try to set Firewall to Custom Ruleset mode, I guess it would prompt you to allow or block requests. Also try to check what happens in Firewall Events log after you try to access inet from sandboxed Opera, maybe could find reasons there.

Hi sanmatross,

Thanks for the suggestions. “Do not show popup alerts” is unchecked so I should get the prompt if there was one, which there is not. As for the logs, there is nohing in the Firewall Events log. I do see entries in the Containment Events log, however, they are no different than those for when I launch the other sandboxed browsers (Rating: Trusted, Action, Run Virtually). As for Custom Ruleset mode, that requires more tweaking than I wish to do, so I prefer to leave it set to Safe Mode.

Well, I meant to set Custom Ruleset just for a while, just for debugging purposes. I guess I would even set HIPS to Paranoid Mode along with Firewall Custom Ruleset just to see how CIS responds to sandboxed Opera actions, or even temporarily disable HIPS and FW to see what might cause the block. I believe there is some HIPS or FW rule that blocks VPN traffic. Anyways, sorry if nothing helps, maybe Comodo staff would be more knowledgeable about your issue.

Oh, OK, sorry I misunderstood. I enabled all of your suggestions, and I got a lot of popups, but none of them were for Opera. I also tried disabling the Firewall (I keep HIPS disabled by default), as well as Auto-Containment, but neither allowed the VPN to operate. Very strange. Logic would seem to suggest that it has something to do with Auto-Containment, since it is only the sandboxed version of Opera that has this problem.

I agree that I need someone from Comodo to assist, but thanks again for your ideas.

If you do not get firewall alerts for Opera without having any firewall application rules for opera, then it may not be a comodo issue. Do you have another security software installed?

I would tend to agree with you, except for the fact that the non-sandboxed version works fine. As for other security software, I am running HitmanPro.Alert.

Opera updated to version 49.0.2725.34 (PGO). The problem still persists. I hope the next version of CIS resolves this problem.

It works here for me on win10 Pro 1709 (16299.19)

Alerts with Opera when activating the VPN inside Sandbox. Allowed and worked fine
Started VPN outside and works fine then inside Sandbox
No other security software running (apart from Comodo)

This is with CIS

Thanks for the feedback, Ploget. Assuming it’s not the Creator’s Update that fixes it, I’m optimistic that your newer version of CIS makes the difference.

I permitted the automatic upgrade of CIS to version and the problem remains :frowning: