Sandbox Notifications

I am running the latest Beta (build 2111) on my production computer as well as having it on a test VM. All settings are identical. But it seems that I am no longer getting a popup from D+ notifying me that a program is being Sandboxed on the production computer, whereas I am getting the D+ alerts on CIS installed in the VM.

I noticed this for the first time with the previous beta build. Any ideas?

ps I hesitated to add this to the bug report forum as it may be that I am just missing something.



What are you trying to sandbox and has it been sandboxed before? Also check to make sure that you didn’t hit one of those silly “never notify me buttons”.

Actually I’m not trying to sandbox anything. For example, as a PDF reader I use PDF-Xpress which apparently has updates that are not whitelisted. When I tried to upgrade the installer wouldn’t run properly, the issue being (as I saw when I opened CIS) was that it was being run as Restricted (my preferred setting) by D+. This was on my production machine.

I tried the same upgrade on CIS that I run in a VM and everything was fine- I got a D+ alert, clicked “don’t Sandbox again”, reran it and it installed. I did at that point verify that the CIS settings of the VM and non VM were identical. Everything is the same except the D+ alerts aren’t showing up on the non-VM CIS.

Actually what I was hoping is to know is if there’s a registry key that contains the switch between Notify and Do Not Notify. I am hoping for some possible registry corruption as the interface checkbox for “Show Notification for Automatically Sandbox Processes” is checked.

Thank you for your response, btw.

Its possible that it may be a bug in the beta. Which VM are you using because I know that Virtual box has had issues running CIS. I’m willing to bet that it has something to do with the virtual enviroment rather than a bug in the system. I would though send a PM to one of the beta mods and see if its a known bug or not. As far as allowing the upgrade on your production machine, you can added it to trusted files when it runs again.

When noticing on your production machine you are getting alerts where you would expect them check with Task Manager if cmdagent.exe is running or not. Make sure you have “View processes of all users” enabled in Task Manager.

The same thing happens to me, as I test out Anti-Malware products myself on Virtual box (Must say Comodo is the best I’ve seen and I use it myself)
I have noticed the beta barely ever shows automatic sand-boxing/partially-limiting notifications at the bottom right anymore like it does in 5.5 and I never see it on my normal machine and its a little annoying having to open up Comodo and going to partially-limited and trusting it.

I have checked that the setting in Defense+ to notify me when it automatically does, but it still does not.

OS: Windows 7 Ultimate 64bit

There are known issues with VirtualBox…you should use VMware Player instead…

But I said it also happens on my own machine which I am using at the moment. (Plus VMware won’t work for me for some odd reason)

The problem is NOT happening for me on VirtualBox. Everything is perfect on VM- it’s on the non-VM computer where this is occurring.

I did try something-

1). On the Production Computer (non-VM where I am having this problem) I uninstalled 5.8 beta using the Uninstall tool found on these forums. I reinstalled CIS beta. I downloaded and ran a legitimate program that I know CIS will sandbox, Puran Defrag. No D+ popup- it just goes to Sandbox.

2). As the CIS on VirtualBox works fine, I exported the settings to the Production machine and imported them to CIS. I rebooted and ran Puran Defrag setup. No D+ popups, program goes directly to Sandbox.

Can’t understand exactly why setup 2 above failed, but hope it doesn’t reoccur when CIS comes out of Beta. But even if it doesn’t I have no cause to complain. I do malware testing for a living and have been hammering CIS with between 20-40 new malware samples 6 days a week for 2 months and for all intents CIS has been flawless.

Thank you for a fantastic product!!!