Sandbox crashes with some files

hello, the sandbox does not execute properly explorer.exe when i start it with the menu entry start in sandbox.
Vkiosk starts and ends directly.
Some time ago this operation did work normally.

Obvious question: Have you made any changes to CIS configuration?

No, i tried it with a vanilla configuration file as well.
I did not make mayor changes in the configuration between the time when it worked and when it stopped working.

Doc! It hurts when I move my arm this way! (moves arm in shocking manner that viewers would infer would be painful)

“Don’t move your arm that way.”

“Well, that’s a fine how do you do; not that you’re any good either as a doctor; otherwise you’d know why my arm hurts when I do this. So now I’m off to find another doctor that can figure out why my arm hurts when I do this.”

So you suggest me just not to use the explorer.exe inside the sandbox?
Actually its not only explorer there are other files that do not work.

I have a question: If the sandbox was messed up by a virus can this cause this kind of behaviour?

Perhaps, not sure though, tried resetting/cleaning the Sandbox?

i have not tried to clean it i would need to first save the app data from inside so i did decide to ask first if there might be a different way.

If you need to save data from the sandbox but you can’t enter the sandbox, then enable showing of hidden files as well as hidden OS system files (Video), then go to C:\VTRoot\ and look for the files you want to save, then move them to a safe directory outside of the C:\VTRoot\ folder.

Besides that the only things I can think of that can possibly fix this behavior is first to clean the sandbox and if that doesn’t work then a complete clean re-install of CIS, maybe there is some other thing to try that I don’t know of, perhaps wait for some other advice before re-installing CIS, and there’s no guarantee that it will fix this behavior anyway.

I there a way to create a new sandbox as seperated entity from the old maybe messed sandbox?

Well if cleaning does not work then i wonder if cis does store some cache maybe precompiled about how to execute things in the sandbox? Or are there other caches or settings that are stored with comodo that might be corrupted?
I will now just move the files out of the sandbox and look what will happen.

Okay i cleaned it now it works again.
thankyou friendly neighbourhood kitty :slight_smile:

When i excute something from the sandbox explorer it will be automatical also sandboxed right?

Not that I know of, if I remember correctly it has been requested before but never implemented.

I don’t really know about caches, I just know that previously I have experienced that CIS databases have become corrupt or at least filled with corrupt data, but that wasn’t in regards to the Sandbox, I don’t know if that could happen for the Sandbox.

Glad it’s working! ;D

That’s the intended behavior yes, anything carried out in the FV sandbox should stay in the FV sandbox, so if a FV sandboxed process (in this case explorer.exe) tries to launch another process then that will also be sandboxed as Fully Virtualized.