Sandbox and Battlefield 4

I just want to report problem here (reported to EA too).
Its impossible to play battlefield 4 on my computer with comodo. Problem is with sandbox - when i turned it off its all fine. When i run BF4 there no reaction (with sandbox on). Its not only my problem, many people had same - thats how i find solution, on some battlefield forum.

Windows 8 64bit and new (free) comodo internet security.

Sory for my english

I am confident that this can be solved. I will therefore move this to the HELP section of the forum.

Also, did you try adding it to the trusted files list? If so then what about the exceptions for shellcode injection?


Can you provide the .exe files for both x64 and 32 launcher?

Hi, thank you for answer

Im didnt put it to the trusted files list - cannot find this option ;/
Exe files i will send to Bogdanr PM if possible [edit: DONE]

Both files are signed by “Electronic Arts” and vendor was found present in TVL. On our side tests went fine. However we’ve also created safe signatures for:

Filename : bf4.exe
SHA1 : 15e0578164785a4356db2da2ab3125e1d05a5e7a
File Version : 1, 0, 0, 0
Product Version : 1, 0, 0, 0
Extension : exe

Filename : bf4_x86.exe
SHA1 : 6fcf9cef596bd3397a683934cdcc80d672dd518d
File Version : 1, 0, 0, 0
Product Version : 1, 0, 0, 0
Extension : exe

Please allow few hours for safe signatures to enter live db then run the game again and see results. Let us know if game works fine

after i turn sandbox on, there still no reaction when i run a game file. Maybe i can see some logs? But cant find it.
I see in “not recognized files” (have in polish, so dont know how to translate) file:
from battlefield/origin folder (sended via PM, i cant send it with comodo function: error - file not exists, but exists :slight_smile: )

The files located in the bf4 “core” folder have a self signed certificate which can’t be added into TVL. Therefore, we have whitelisted all files from that specific folder but also the valid signed ones to cover any TVL bugs. Please update your CIS to 17370 DB and see if it works ok now.