SafeSurf Update Error

I installed the new Comodo Firewall version with SafeSurf, however, when I right click the SafeSurf icon in the system tray and select “check for updates” the update screen pops up saying “update error !” with the green bar about a third of the way complete. Is this normal? I made sure that it is allowed by cfp so that isn’t the issue. Any help would be appreciated, thanks.

It could be a CFP issue, try disabling Comodo Firewall completely and then try to update the program. What happens?

I disabled both the firewall and defense+, restarted, and tried again. I got the same update error result. Does it update for you?

I do not use the software so I cannot say, but I had you disable the firewall completely to see if it was a conflict of some sort which it seems to not be.

If you could give me a link to the latest version I will install it and see if I get the error.

Well you have to download the newest comodo firewall and install safesurf w/ the ask toolbar option. Here is the link to the 32-bit version from the Comodo website:

Ah sorry, reading over my last post I can understand how it could have been confusing. I meant the link to the program SafeSurf. I googled it but could only find a program called SafeSurfer, are these the same? That’s why I wanted a link to make sure I downloaded the same program as you are using :wink: I already have the latest Comodo Firewall running :slight_smile:

I’m not sure if they are the same but if you installed the latest comodo firewall and didn’t opt out of the toolbar option then you should have the system tray “COMODO SafeSurf v1.0.0.5” icon. That is the one I am referring to. Right clicking it should show an option to “Check For Updates”.

Ohhh, I see what you are talking about!! I misunderstood and thought you were referring to a different product :stuck_out_tongue: Looks like I will need to do a clean install, will get back to you in a few minutes.

Okay, I’ve installed SafeSurf and I am receiving the same error as you, it looks like this is a server side issue. My guess is that the server admins are updating something on the server making it temporarily unavailable.


Okay, I was hoping it might be something like that as opposed to a program problem. Thanks for testing.

Still getting the error when trying to update. What’s the deal?


well if everyone is getting the error don’t worry about it. its not just you.

I am confirmed bug, i am vista 32 bits sp1 comodo v

I have the same problem.

I am running CFP v3.0.25.378 + SafeSurf v1.0.0.6 + Vista

The error message says my internet connection settings is bad.

                      could we see a screenshot please?