Safelist database

environment: WinXP (latest SP’s) running CF ( and CAVS(

I receive the following error when running scheduled scan:

“Error 002 Unable to load safelist database”

Right click and scan now work fine, have tried running scan now to recreate safelist database but no joy. Has anyone any experience with this problem?

Apologies for any cross postings, I’ve been unable to find anything on this in the forum.

Thank you!!

I have had the same error message on only a couple of occasions - most of the time the scan runs without problems. Strange…


This problem is consistent and reproducible. I’ve tried re-creating the safelist DB using the UPSDbMaker.exe utility but sill the problem remains. I wonder is there a size or filecount limit on the safelist DB?? I ahve some 12000 files on my system and wonder if this is perhaps the cause of the probem.

Can anyone tell me how to manually delete the safelist db so that I can try and recreate a “clean” copy??

Thank you!!

Can’t guarantee this, but you might look at c:\Documents and Settings\All Users\Application Data\Comodo\Antivirus\SafeDB.


Thank you - I’ve tried unsuccessfully to rename this directory and to try and manually recreate the safelist DB but the problem remains. Have also tried a full uninstall (including deletion of the safelist DB). Does anyone know if there is there anyway I can force the program to not use the safelist DB?? I run my scheduled daily scan late at night and am not bothered if the scans run slowly or are resource intensive.

Any help would be appreciated as otherwise I’m happy with CAVS - I’d hate to have to replace it because of this bug.



This is worth lodging a ticket at the officail support centre (

Please include the details from your first post, along with the installation path and whether this error occurs under the same login that was used to install the product.

Hope this helps,
Ewen :slight_smile:

Cheers Ewen, I’ve contacted support and will see what they make of this problem. Thanks to everyone concerned for their help.

all the best,Rich

Hi riku,
How many scheduled scan task you have? Does scanner work fine if you have one scheduled task at a time? This error “Error 002 Unable to load safelist database” seems to come sometimes if multiple scheduled scan starts.
You should not delete or rename SafeDB folder, otherwise scanner will fail to load safelist database everytime. If you you have already deleted any db file/folder, pls reinstall CAV and try again.


Hi Kishork,

Thanks for your reply. I only have a single scheduled scan (my computer) running nightly - no the error002 appears anytime a scheduled scan runs. Since my last re-install of CAVS I now have the error002 anytime I try a scan (scheduled or otherwise). Have reported this to support but no answers from them yet. VERY frustrating as I’ve tried everything I could think of to correct the problem - it seems to be a fairly solid bug. I’m wondering if anyone else out there is experiencing this problem…

Thanks again,Riku