safe:// and kisok:// commands don't work in dragon but they work in other browse

[[[[[[[ i was not able to post this in the bug report section because there was nothing to click on to post a new topic]]]]]]]

if you type in a site like youtube or any site as shown below in dragon it will perform a search instead of opening the desired site in a virtualized browser or opening a site in the kiosk depending on the command used.

safe:// (open site in virtual browser)
kiosk:// (open site in kiosk)

if you use any other browser it will open the site in a virtual browser or kiosk but it will not be opened using the browser you typed the site in. it will open in whatever you have set as the default browser. so if dragon is set as the default and you type safe:// in IE then it will open in dragon. if you type kiosk:// in IE it will open in the kiosk but use dragon or whatever your default browser is.

the commands should work and dragon and the sites should open in the browser they were typed in. so if i use safe:// or kiosk:// in IE and dragon is set as the default then it should open the site with IE not the default browser.

“safe:// and kisok://” are replaced by the “switch to virtual mode” for CD and CID.

no they’re not replaced. it’s an addition. they still work in CID

would you like me to forward this to the bug section?

if you could

As this does not appear to be a CIS bug I will move it to a more suitable topic.

Also, this help page seems to indicate that perhaps they have removed that particular functionality. Can anyone clarify whether those shortcuts are still intended to work?

they work with every browser including ice dragon but does not work in dragon. so I think it’s a bug in dragon or a conflict between dragon and cis.


The commands work in Dragon only the steps are slightly different from other browsers (IceDragon and IE for example).
The option has to be selected from the suggestion box (see attached screenshot).


[attachment deleted by admin]