Running MSE and CF causes Kiosk and sandbox to completely freeze PC [V6][M597]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Yes. It always happens, although sometimes my PC freezes sooner and sometimes later.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:

[li]First: Kiosk never ends loading. And the first time I tried opening it, it ended freezing my entire PC.

  • Second: I tried running some programs in the sandbox. They worked ok. Then I just started doing other things like browsing the web, and 30 minutes later the entire PC freezed again.

  • Third: I tried to find the cause, so I run Kiosk again. Kiosk kept loading. So I tried to kill the process. It did anything. Then I tried to run a program in the sandbox, it didn’t start. Then I saw that it appeared another virtkiosk.exe process. Everytime I tried to load a program in the sandbox, it appeared another virtkiosk.exe process and nothing happened. None of those processes couldn’t be killed. Then I saw that I couldn’t run any program. The Desktop stopped responding. I couldn’t open or kill any process. Ctrl+Alt+Supr gave me a black screen with a weird message. Till I had to force a shutdown.

  • Fourth: After the suggestion of reinstalling COMODO with the help of some uninstaller tools from this forum, Virtual Kiosk no longer displays the loading screen properly. Now it only shows a white rectangle.

  • If not obvious, what U expected to happen:
    Being able to run virtual kiosk and run programs in the sandbox without freezing and without instabilities.

  • If a software compatibility problem have U tried the conflict FAQ?:

  • Any software except CIS/OS involved? If so - name, & exact version:
    No.

  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    All the freezes happened gradually. The desktop stops responding, then some apps, then the taskbar, then everything. Not necessarily in that order. Resetting the sandbox didn’t fix anything either. When sandboxing a program, it seems that there are programs that make it go instable faster, like some installers and some simple .NET programs. Those programs never load sometimes even if the system is still stable, but the process still appear.

In the Windows Event viewer I saw some system errors with ID 7034 that said something like “The COMODO Virtual Service service terminated unexpectedly. It has done this 3 time(s).”

  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)
    [/ol]

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:
Version 6.2.285401.2860, Firewall Security configuration.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    HIPS: Safe, Firewall: Safe.
  • Have U made any other changes to the default config? (egs here.):
    No.
  • Have U updated (without uninstall) from a CIS 5?:
    No.
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:
    No.
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7, SP1, 64bit, UAC: Default mode (“Notify me only when programs try to make changes to my computer”), administrator, no VM used.
  • Other security/s’box software a) currently installed b) installed since OS:
    a=Microsoft Security Essentials, Malwarebytes, Spybot - Search & Destroy b=Microsoft Security Essentials, Malwarebytes, Spybot - Search & Destroy and Comodo Firewall 5.12.
    [/ol]

[attachment deleted by admin]

Have you tried disabling MSE, Malwarebytes, and Spybot, to see if the freezing still occurs?

If not please check this and let me know if disabling all makes a difference.

Thank you.

Oh, my. Disabling real time protection from MSE, Kiosk finally worked. And I didn’t have problems with sandboxing either for now.

So I guess it’s a compatibility issue.

Thanks for checking. Now that we’ve narrowed down the cause I can forward this to the devs. There is a bug of some sort as CF is supposed to be able to run alongside MSE.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Can you please check and see if this is fixed with the newest version (6.3.294583.2937)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Nope, not fixed. It happens the same.

Thank you for checking this.

I’ve updated the tracker.

I’m sorry, but the devs have responded that they will not be able to fix this issue. The problem comes from some sort of an incompatibility between MSE on your system, and the CIS sandbox. It appears that there is no easy fix for this, and thus they will not be able to fix this issue.

Therefore, I will move this to Resolved. I’m sorry that more could not be done.

This issue is fixed in CIS 8.2, now CIS can work with MSE.