Running LotRO w/ Comodo

EDIT: Posted this here so folks will see it first. Quick background: Uninstalled Zone Alarm and installed Comodo. Tried to run Lord of the Rings Online but it would hang on the “Open Main Form” window. Rest of this thread is a lot of nice folks trying to help. But…

Turns out it was indeed a game file problem. No idea if the ZA uninstall, the Comodo install, or just coincidence caused it. If you have a similar problem go here:"main+form"

About 1/2 way down 1st page look for the post by Impetuous regarding the TurbineGDF.exe. Fixed me right up :BNC

Thx to all, especially Kyle who spent so much time with me today I’m pretty sure he can take me as an exemption on taxes next year (:SHY), who responded.

I am now officially a Comodo convert (R)

did u see this sticky?

Yeah I did. I followed everything he/she suggests except I wasn’t sure what “clean install” meant. I removed ZA before I installed, choose the learn everything mode, and the LotRO binaries show up. Still nada. If “clean install” meant start from scratch with new OS install etc., sorry that’s not even a little worth it, I’ll go back to ZA and call it a day.

I play several different MMORPGs and the following method always worked for me:
Delete any references you may have accrued for LotRO, then set both the firewall and defense+ to Training Mode. Boot up the game and play for a little bit to let Comodo learn what is going on. It will create its own rules for the behavior it sees. Then after you log out, reset the firewall and defense+ to whichever setting you had previously.
That should make everything work fine. Like I said, I’ve done this a few times and I haven’t had any problems so far. Good luck!

Thx all for feedback but still not happening. Even uninstalled and re-installed Comodo. Set everything to training and tried, still hangs same place. /shrug

Only thing I can guess is LotRO is either trying to call something or has passed control to something that the FW is blocking. Not sure why I’m not seeing an alert though. I have alerts pretty much set to max for everything just to try to see what the hold up is but not seeing anything.

Back to the drawing board I guess (:AGY)

Hello Oldgrump, Sure we can find a solution to this :slight_smile:

Can you please do this for me;

Comodo → Firewall → View Firewall Events Is anything being blocked there?
Comodo → Defense+ → View defense+ events Is anything being blocked there?

Also, does this LOTRO use any sort of “Anti Hack” Program? to stop cheaters etc

Only thing appearing in Logs is D+ log shows when I switched between Safe → Training and back. FW log has nothing. As for the anti-hacking thing - no it doesn’t. I read somewhere in here that somebody had to turn of D+ because of an anti-hack another game used. I even tried turning D+ off, nada.

Just to make sure it isn’t a problem with connections, I’ve taken to accessing various LotRO sites via IE & tracert while the game is hung trying to run. This one has me stumped. All I needed to do in ZA was make sure 3 exe’s were Allowed and no problems. I’ve set all 3 of those same exe’s to Trusted in both FW & D+ and still hangs. Doesn’t take much but I’m sure stumped :slight_smile:

Any ideas and pass them along I’ll try anything. Hate to go back to ZA, what I’ve seen in Comodo so far it blows the doors off ZA.

Alright, Do this for me please

ComodoDefense+AdvancedComputer Security Policy → * Look for anything to do with LOTRO and delete the entries and apply*

Do the same with firewall;

Comodo Fire Wall AdvancedNetwork Security Policy → * Look for anything to do with LOTRO and delete the entries and apply*

Now put D+ and fire wall in training mode and try running the game again.


If that doesn’t work I really am stumped, Because that should be starting “A Fresh”. Maybe it’s not comodo at all, To check this just uninstall comodo and try running your game. Could other Software be interfering?

K did that. Saw a lot of balloon msgs couldn’t read them all, no alerts. FW log empty & D+ shows the Safe → Training. No dice :frowning: Maybe I posed the wrong question in LotRO forums. No idea how uninstalling one FW and reinstalling another would do this but, maybe one of the LotRO files is screwed up somehow and the game hanging after Comodo install is just a freaky coincidence. /shrug.

Unfortunately only way to double-check that is to uninstall Comodo and reinstall ZA and test it. Appreciate the help but if there’s nothing else obvious you can think of guess I’m stuck trying that just to see.


Just check by uninstalling comodo first off. Try running your game without a firewall. If it still doesn’t work… You might not have had a clean uninstall of Zonealarm.

K uninstalled Comodo, ran game, hang in same place. lol the question is: 1) Did ZA leave something behind that messed with the Comodo install; or 2) Did Comodo not fully uninstall which is causing a block still; or, lastly, 3) Did a problem just happen to crop up in the game files at the same time? Interesting, very interesting.

Going to post new info on LotRO boards and search there to see if anyone else reports a problem at that particular point in the game. I’m hoping it’s just a couple files messed up there. Don’t even want to think about partial uninstalls of ZA or Comodo :slight_smile:

Thx for help. I’ll get back with anything I find out, assuming it actually works :wink:

I highly doubt it’s comodo, Zonealarm has been known to leave traces of it’s self laying about interfering with other applications.

look here;