runas error, crashes in a row, ntdll.dll

Hi!

Comodo Firewall (free) : 3.5.57173.439

I got multible crashes most of the time when I trie to run a application as administrator from an normal user account by runas.
This is followed by crashes like that (translatet from german):
explorer.exe, Version 6.0.2900.5512, Module ntdll.dll, Version 5.1.2600.5512, Adresse 0x00010193

drwtsn32.exe, Version 5.1.2600.0, Module dbghelp.dll, Version 5.1.2600.5512, Adresse 0x0001295d

There are no crashes when i am disable the AV engine

Hi vsk,

Welcome to the forums, could you give us a little more detail on this ?

  • What’s your OS/version/servicepack
  • Do you have other “security” applications active ?
  • What are the “tools” you try to runas, so maybe we can test and reproduce it ?

I assume your are setting Real-Time scan to disabled to fix this problem ?

Regards,
Ronny

sorry for the mission information

OS: Windows XP Prof. SP3

No other Security App active, but installed.
Avira Anti Virus is installed BUT active guard is NOT active (disabled that feature at installation)

Spybot Secure & Destroy is installed but no active component is running, no immunisation or something like that was done

explorer crash caused by right click menu → runas
problem seems to be on every “tool” i try to run, for example

  • total commander
  • processexplorer
  • something i wan t to install, like a game or patch/addon (not ■■■■■!) for a game
  • system stuff ->*.cpl

yes when i disable the real-time scan, there seems no problem but while testing on / off scan explorer.exe crashes one or two times too
by the way, sometimes the runas window appears( bevore crashing) but looks different to the normal style, there is less text in the box…

could it be that there is a conflict with that signature check by windows? on my other computer everytime i wan to start an app windows asked me if i want that to do, don t know how that feature is called… Havn t seen that box on this machine here for a while…

Hi vsk,

I think the fasted way is to export you current settings from CIS uninstall CIS and see if the problem is totally gone, also the explorer crashes, if so the I’d try to uninstall Avira, check again. Then Install CIS again optionally import the policy again and have Real-Time AV active, check again and see if it’s gone.

Problem with multiple AV’s installed can result in very strange behavior, a “disabled” AV can still be “active” on the background if it hook’s to some windows functions. And having to apps hook to the same function can cause strange behavior.

Sorry for not responding for such a long time.

I have done a complete renew. Running Comodo Suit on my machine without any other security stuff causes NO problems!
Everything is running fine now.

Before complete OS renew i have tried different de/re/installations but that havn t worked.

THX

No problem,

Looks like something somewhere along the line messed something up… that tends to happen on OS’es sometimes…