"Run in COMODO Sandbox" right-click action is not shown for .MSI [M1035]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Every time.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1: Right-click on any application with .MSI extension.
    2: You will observe that there is no “Run in COMODO Sandbox” action as you can see in the picture named “rightclick-msi.png” that I attached.
  • If not obvious, what U expected to happen:
    You should be able run virtually .MSI by right-click action.
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    This is a defect. Apparently, there is support for .EXE only as you can not run .MSI from “Sandbox Tasks” > “Choose and Run” as you can see in the picture named ‘screenshot.png’ that I attached.
    A possible work-around is to type “.” in “File name” field. Screenshots are attached to this post.

[ol]- Exact CIS version & configuration:

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
  • Have U made any other changes to the default config? (egs here.):
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    OS: Windows 7 Home Basic 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.140303-2144)
    UAC: Disabled
    Account type: Administrator
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=None b=None

[attachment deleted by admin]

I’m trying to fully understand this. Are you saying that there is a way to get .MSI files to always be run Fully Virtualized?


I’m trying to say that MSI should work just as well as EXE but there is no support as it does not show up in the list (only EXE shows up, see screenshot).
And yes, it’s possible to virtualize MSI by entering “.” (without quotes).

The right-click option for MSI is missing.

Can you please post a few screenshots showing how you can get a .MSI file to be manually run sandboxed. My understanding was that it was not possible. Thus, it’s important that I fully understand how you are accomplishing this.

Thank you.

[attachment deleted by admin]

That is very interesting. Have you found any problems running .MSI files sandboxed in this way, or does it seem to work just as well as with .EXE?

Apparently, it works the same. Right-click option is missing.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Side note,

Seems like .MSI is not considered as executable file since it’s missing in “Read from a signed executable” window from “Trusted Vendors List”. Please check attachment.
Perhaps using “All Files (.)” only might be a better approach (in this case).

[attachment deleted by admin]

Good idea. :-TU

qmarius has informed me that this is fixed on their system for CIS version 8.0.332922.4281. I will therefore move this to Resolved.

Thank you.