Rules are ignored when alerts disabled (v3.0.18.309 x32) [FIXED]

  1. CPU (32 bit or 64 bit)
    32 bit
  2. Operating System information (including Service Pack Version)
    Windows XP Professional SP2 with all subsequent updates installed
  3. Actively-running security and utility applications
  4. Specific symptoms of the bug, and steps you can take to reproduce it (step by step).
    Any incoming and outgoing traffic is blocked despite of all necessary (allow) rules are present in “Network security policy”.
    Alert settings: “Alert frequency level” - high, “Enable alerts for TCP/UDP/ICMP requests” - all disabled, “… connection gateway” - disabled, “alerts for loopback requests” - disabled
  5. Specific steps you have taken to try to resolve it.
    Enabling “alerts for TCP requests” is making the firewall to handle TCP rules fine. (but I don’t like these stupid alerts!)
    Changing “Firewall security level” to disabled are also OK (allowing any traffic).
  6. Brief description of your Defense+ and Firewall+ mode (Custom, Train with safe) plus mention if you modified any setting in ADVANCED section of D+ and F+
    Firewall security level - “Custom policy mode”
    Defence+ security level - disabled (deactivated permanently)

Are you having problem in connecting to the Internet for all sort of applications defined in Network security policy or only to the specific application. If the CFP is blocking only the specific application then whats the rule u have created for it…

Note:Setting the Firewall Policy in Custom Mode and disabling the alerts will not allow any unknown application to connect to Internet because firewall needs to know what sort of action should be taken for that particular request…So, It has to alert the user.


I’m Sorry… Just now verified ur issue and it seems to be a bug…Its a very good catch… (:CLP)
Steps to Reproduce the issue:
set the following rule for I.E:
Allow IP out from IP any to In Loopback zone where protocol is any
Allow UDP Out from IP any to IP any where source port & Destination port is any
Allow TCP Out from IP any to IP any where source port & Destination port is HTTP ports
Block and Log all unmatching requests

Set the Firewall in Custom Policy Mode.
Firewall Behavior settings:
Alert level:High
Uncheck Alert for UDP TCP Loopback and ICMP

   The only way to connect IE to internet is enabling the UDP alert. Also It seems that ICMP packets are also blocked even if we have rule defined in Net. Security Policy.


still not fixed in :cry:

fixed in 3.0.21