Rule Creation Issue

Hi all,

I finally updated from CIS 7 to 8.2 today (since it is possible to disable ADS now) and now I’m having a new serious problem with rule creation. I initially updated from v7 to v8 but also tried a complete uninstall/reinstall to no avail. I’m importing my configuration from v7. Now, sometimes for certain applications, which don’t seem to have anything in common (NXClient v3.5.0.9, TeraCopy v2.3), Comodo completely disregards the current ruleset and keeps showing alerts for these applications even though there is already a rule corresponding to each alert in the ruleset and even if I answer the new alerts with “Remember my answer” checked, which might or might not result in duplicate entries being created in the ruleset, Comodo will keep showing the same alerts if I close and re-open the application. I even tried completely deleting all rules for such applications and make the rules from scratch by answering Comodo’s alerts but the same thing happens. This doesn’t only apply to Comodo’s HIPS module but also the Firewall module and for the same applications. I have attached a screenshot from a strange case of duplicate rules (this isn’t always the case, sometimes the duplicate entries are exactly the same and sometimes they’re different and sometimes there are no duplicate entries). Needless to say, this only happens to a small portion of my applications and the rest seem to work fine. I have successfully created new rules for some new applications without facing this issue.

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
100% reliably.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Launch NXClient or TeraCopy (or other applications I haven’t discovered yet).
2: Answer alerts generated by Comodo’s Firewall or HIPS modules with “Remember my answer” checked.
3: Close the application and relaunch.

One or two sentences explaining what actually happened:
Comodo keeps showing the same alerts even though they have been already answered and remembered and do show up in the ruleset.

One or two sentences explaining what you expected to happen:
I obviously expect Comodo to stop showing alerts I have already answered which were marked as “Remember”.

If a software compatibility problem have you tried the advice to make programs work with CIS?:

Any software except CIS/OS involved? If so - name, & exact version:
NXClient v3.5.0.9, TeraCopy v2.3, etc.

Any other information, eg your guess at the cause, how you tried to fix it etc:
I think it might have something to do with the fact that I’m importing my ruleset from v7 and the fact that I think Comodo 8 uses a different database.

Exact CIS version & configuration:
CIS v8.2.0.4508.

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
AV: Stateful
Firewall:Custom Ruleset
HIPS: Paranoid

Have you made any other changes to the default config? (egs here.):
I have changed pretty much everything in comparison to default settings, and tuned them towards maximum security.

Have you updated (without uninstall) from CIS 5, 6 or 7?:
Yes, from v7.0.55655.4142.
if so, have you tried a a a clean reinstall - if not please do?:
Yes, same issue.

Have you imported a config from a previous version of CIS:
Yes, from v7.0.55655.4142.
if so, have you tried a standard config - if not please do:

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7 Sp1 x64, UAC disabled, administrator account, no virtual machine.

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=No b=No

[attachment deleted by admin]

similar behavior here. (since today i guess. 3 hours ago)
the same .exe files keep popping up though i know there was a rule and also after make comodo remember a new rule.

Ich have the same problem. I think this bug is related to this bug report: Please fix this fast because a firewall nagging you with the same questions is nearly unbearable.

Should be fixed in version <>. If it’s not fixed, please PM me and I will move this one back for further processing.