Router does not recognize Ice Dragon

I wanted to try Ice Dragon, but it doesn’t seem like the router that I bought supports it. I tried typing the router address into the url bar and it comes back as not found just as everything else I have tried comes back the same. I bought a Linksys N300 and it works fine with Firefox and Chrome and I guess it works with IE I just haven’t opened it to find out. Any suggestions?
Below is what it reads every time I try it.

Server not found
IceDragon can’t find the server at
Check the address for typing errors such as instead of
If you are unable to load any pages, check your computer’s network
If your computer or network is protected by a firewall or proxy, make sure
that IceDragon is permitted to access the Web.

Hi kirkd,
Go to Options, Advanced, General and under system defaults try disabling malware domain filtering (Comodo Secure DNS) if you have it enabled.
This probably should not effect or help the issue, it is just one thing that came to mind that is different to other browsers.

:frowning: If it could be made worse it did. Now it doesn’t even pretend to connect. I went into firefox settings and compared the two what I could and made sure what matches were the same.
I opened up the router settings and could not find a place to add a browser. Little frustrating. This may help someone, I have put in Hughes Net through Frontier Communications, with a Linksys N300 router. Dial up is still connected I will disconnect sat and try dial up to just see.

Doesn’t work on dial up either.