RocketDock issues with Sandbox

After enabling Sandbox with the latest FW 4.1 version RocketDock even after allowing the process still didn’t work when trying to run an applet from the dock. After e.g. trying to run My Documents shortcut it constantly asked me what app (default explorer) should be used to open, obviously because the Sandbox must have quarantined registry entries.

After disabling the Sandbox and restarting the computer everything worked fine.

OS: XP Home SP3 x32
Security: Avira Personal latest, CFP 4.1

Additional notes:

The Sandbox still needs to be revised as it quarantines common apps such as Realtek HD Audio and stuff.

we are going to be making a new update to our “Cloud Services” which is already included in v4.1. This will update over 6M new executables which will drastically reduce the no of applications that go into sandbox.



Have you tried adding the file concerned to ‘My Safe Files’. You should not need to disable the sandbox.

If this does not work, hopefully something else will. You’ll need to post Defense plus logs though, and give us a little more info about Rocket Dock and what you are doing with it. Is the My documents shoortcut related to RocketDock?

Best wishes


Hey Mouse1,

I did add all the files as trusted, didn’t help. So I had to disable the Sandbox completely and then it worked.

What I did was I clicked the My Documents shortcut on my dock and instead of opening explorer it opened a window to choose what program to open with, so clearly a registry issue.

Was anything sandboxed at the time your PC started up. If so it’s possible that a startup program that was necessary was running sandboxed and therefore restarting your computer, or the service, would solve the problem.

Please give further details as requested here.

And attach a screenshot of your Defense plus logs.

Best wishes