Right clicking to sandbox files does not work with shortcuts on Win 8[M599][V6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:Every time
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:right click on any program shortcut like a desktop icon and choose “Run in Comodo Sandbox”. The program will not open at all
  • If not obvious, what U expected to happen: Program to run in the sandbox like it does with every version of Windows but Windows 8
  • If a software compatibility problem have U tried the conflict FAQ?: N/A
  • Any software except CIS/OS involved? If so - name, & exact version:No
  • Any other information, eg your guess at the cause, how U tried to fix it etc:If you navigate to the actual .exe for a program and right click on that and choose to run it in the sandbox, it works. It does not work from a shortcut
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)
    [/ol]

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:6.2.285401.2860 Internet Security Config

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:Hips disabled, BB on Untrusted. Firewall in Safe Mode, AV stateful
  • Have U made any other changes to the default config? (egs here.):Auto-quarantine off, Firewall alerts enabled for unknown things
  • Have U updated (without uninstall) from a CIS 5?:No[li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:No
    [li]if so, have U tried a standard config - if not please do:Standard config
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:Windows 8 Pro 32 bit. UAC on defaults, Admin account, no VM
  • Other security/s’box software a) currently installed b) installed since OS: a=Malwarebytes free b=Same
    [/ol]

I think I may have discovered the problem with opening programs in the sandbox through the right click menu. If you right click on a shortcut to the program and choose to run it in the Comodo Sandbox it will not open. If you navigate to the actual .exe for the program, right click on that, and choose Run in Sandbox, it works. In Win 7 and all other Windows versions you can right click on a shortcut and open things in the sandbox. It doesn’t work in Windows 8.

[attachment deleted by admin]

Please put your report in the required format. This will also help me to better understand the situation and ask relevant probing questions.

Thanks.

I have moved the bug report from here and inserted it in the first post.

[attachment deleted by admin]

When you say Malwarebytes, do you mean Malwarebytes Free or Malwarebytes Pro?

Other than that I will say that this appears, at least to me, to be a bug. Please attach your diagnostics report and Process List to your formatted post so I can forward this to the devs.

Thanks.

Malwarebytes free and I don’t know how to find those things you want attached.

Honestly, even having to use a formatted form is a ridiculous imposition and something every user of this forum should refuse to use so it goes away. I think I have provided more than enough information for this issue to be investigated.

I am not running Windows 8, and therefore cannot test this myself. Thus, in order to ensure that this bug is fixable I am forced to conclude that it’s possible it’s specific to your computer, or perhaps to a combination of software. Thus, attaching the diagnostics report, and the Process List, allow the devs to identify the problem even if this does turn out to be the case.

The diagnostics report can be found by opening the main CIS GUI. Then click on the question mark near the upper right corner. Select support and then diagnostics. This will create a zip file, which you can then attach to your post.

For the process list, the easiest way to do this is to open KillSwitch. Then click on the menu for KillSwitch and select “Save Current View”. Then put this in a zip file and attach it to your post.

Once you do this I can forward this to the devs.

Thanks.

Okay the zip files are attached.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

The more details a user provides, the better the chance the developers will be able to replicate, and therefore fix any reported bugs…

Yes, it may seem like a chore, but with countless system configurations out there, it’s a necessary step.

I just tried it and I am able to sandbox programs using the shortcut in Windows 8 so it doesn’t seem to be an issue with all Windows 8 installations.

Thank you.

In that case perhaps it is related to a specific program. Has anyone else tried with Classic Start Menu installed?

I have Classic Start Menu installed but that was not the problem. I have discovered the reason and corrected it.

To start with, I do not like the arrows that Windows puts on Desktop Shortcuts so I had applied a registry hack that has worked since Win98. You go into HKEY_CLASSES_ROOT, find the keys for lnkfile and piffile and delete the entry called IsShortcut. That causes no problems in any version of Windows except, apparently, Win 8. I restored those two string values and now all the programs will open in the Comodo Sandbox through the right click menu.

I still don’t like the arrows so I downloaded a portable utility called WindowsShortcutArrowEditor that lets you remove the arrows or choose how you want them to look. I used it to remove the arrows and now everything is fine.

Okay, in that case I will move this to Resolved.

Thanks for following up. This may be helpful to other users who make similar alterations.