Right Click Scanner gives "Antivirus Engine is not initialized!" error.

* CPU (32 bit or 64 bit): Intel Q9550 (64 bit)
* Operating System information: Vista Ultimate 64 bit with SP2
* Actively-running security and utility applications: CIS 3.9.95478.509; Virsu sig db version: 1164;
Avira AntiVir Free 9.0 in StandBy Only mode.
* Specific symptoms of the bug, and steps you can take to reproduce it (step by step).
1. Previously had CFP 3.0. Uninstalled completely. Cleaned Comodo hives in Registry.
2. Installed Vista SP2.
3. Installed CIS 3.9 Build 507. Updated to 508 and then to 509 - over the course of 3 days.
4. Defense+ Works, Firewall works. AV Realtime scanning works. AV Manual and scheduled scanning works. AV definition updates work - both automatic and manual.
5. Today, tried Right-CLick scanning for first time. and got a popup saying “Antivirus engine is not initialized”.
* Specific steps you have taken to try to resolve it.
1. Tried unregistering and re-registering “cavshell.dll”.
2. Tried starting a manual scan, stopping it after a bit, rebooting. Apparently worked for some others, but, not for me.
3. Tried deleting “bases.cav” and restoring from the Repair folder in Safe mode. No difference. Manual scan and updates work fine. Right-Click scan gives the error.
* Brief description of your Defense+ and Firewall+ mode
Defense+ in Safe mode; Firewall in “Custom Policy” mode.
* Report if you are using an Administrator account Or a Limited User account.
Administrator account with UAC disabled.

I have this error also…

CPU Typ DualCore Intel Pentium D 925, 3000 MHz (15 x 200)

OS Name Microsoft Windows XP Professional SP3

Comodo version : CIS 3.9.95478.509

Avast 4.8 works correctly without errors with comodo

http://mitglied.lycos.de/ab01/CIS-bug.JPG

error after update from CIS 3.8 to 3.9

all systems are running only Right Click Scanner gives error

  1. Uninstall comodo completely and delete old files

2.reboot system

3.Install comodo and the Right Click Scanner bug is fixed