right click > scan with comodo antivirus won't work in File manager


First of all, I would like to say thank you for you hard work and excellent products.
I’ve searched within this forum but did not find any proper solutions yet.
I regularly use Directory opus (file manager) but the context menu when perform right click,
“scan with Comodo Antivirus” did not work (no scan windows) but when I tried this method
with windows explorer, it works flawlessly. The solution for this problem is to add more
context menu within Directory opus by insert command “C:\Program Files\COMODO\COMODO Internet Security\cavscan.exe” %1 and it works as it should do. But I think this is not the proper solution because now I have 2 similar context menu named “scan with Comodo Antivirus”, the default one
and another one which I’ve created.

any suggestions for this matter?
Thank you and best regards,

here works normally.
Picture 1 and 2 shows that
Tried a clean install of the latest version yet?

[attachment deleted by admin]

Thank you, liosant
Your pictures confirmed that I have a problem.
BTW, wanna give more information about my system.

  • Windows 8.1 pro x64 (upgrade from windows 8.)
  • Directory opus pro x64
  • CIS premium 6.3.297838.2953 x64 (uninstall 6.2 after upgrade from windows 8 to 8.1 because an incompatible issue and clean the leftover file and registry by ccleaner, after that I did a clean install of 6.3.297838.2953 on windows 8.1)
    So, I’m not sure whether the problems came from Directory opus or CIS or bugs in my system, but for now I’ll stick with double context menu as long as it can scan file by comodo antivirus LoL.

Thank you and best regards,

I have the similiar issue using Directory Opus and Comodo Internet Security 7.0.317799.
In windows explorer, right click to scan for virus and to sandbox work normally.
In Dopus, right click to scan for virus earn no response but sandbox work normally.
I found that if I elevate my dopus to administrator mode, both scan and sandbox will work normal.

How do you(I) elevate my dopus/mmm+ to administrator mode ?

My context menu will not respond when I try to ‘scan with comodo antivirus’ …
nothing happens