Right click scan apparently not working with MultiCommander [M179]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:

I can reproduce this every time.

  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:

When i am in my File manager, then all i have to do is right click a file or a folder and the option to use “Scan with Comodo” is present. ( See attached screenshot. ) But when i click on “Scan with Comodo” nothing happens, no matter how long i wait?

  • If not obvious, what U expected to happen:

I expected the file or folder would be scanned.

  • If a software compatibility problem have U tried the conflict FAQ?:

There was no need for looking at the FAQ in my opinion. It has always worked up to and including a fully updated CIS v5.12.

  • Any software except CIS/OS involved? If so - name, & exact version:

MultiCommander v3.2.1 build 1432 64 Bit edition.

  • Any other information, eg your guess at the cause, how U tried to fix it etc:

I have no clue as to why it is happening, nor do i know how to fix this problem. I do know however that the right click option “Scan with Comodo” does work when in Windows Explorer and in the Start/Download Folder.

  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:

CIS v6.2.282872.2847 with ProActive configuration.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:

All modules. Hips: Deactivated / Auto Sandbox: Untrusted / Firewall: Safe Mode / AV: Statefull

  • Have U made any other changes to the default config? (egs here.):

Yes, i have used Chirons install Guide for CIS v6.

  • Have U updated (without uninstall) from a CIS 5?:

No i have not.

[li]if so, have U tried a a clean reinstall - if not please do?:

Yes i first did to the letter what was written here…

After that i used this guide from Chiron as well to install and configure CIS.

[/li]- Have U imported a config from a previous version of CIS:

No i have not.

[li]if so, have U tried a standard config - if not please do:
[/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:

  • Windows 7 Home Premium 64 bits fully updated.
  • UAC is deactivated.
  • Administrator Account only.
  • No use of VM.
  • Other security/s’box software a) currently installed b) installed since OS: a= b=
  • Spyware Blaster v5.0

Was not previously installed, i started using it a few weeks ago.

  • Malwarebytes Anti-malware Free edition

Was previously installed as well, but since it is the free version there is no realtime issues, it is only on demand.

  • Emet v3.0

Also previously installed.

[attachment deleted by admin]

No probs - this is where it should be.

All is explained in the guide, format, and what happens to my bugs stickies.

Best wishes


Thanks Mouse1. :slight_smile:

I’d be very grateful if you could make a report in the standard format please

Here is a link to it: https://forums.comodo.com/bug-reports-cis/format-please-use-it-t61845.0.html


Sorry for the late reply mouse1.

But i reverted back to CIS v5.12. If it hat been just the problem i mentioned in this thread then i would have kept CIS v6, but it was not the only thing i noticed today. When i looked in Process Hacker i saw that the CPU load was constant between 50% to 60%, and the RAM usage around 45%. Also browsing quit slower then before.

So i used CCE to see if something was going on, and nothing odd turned up. Then i checked in Killswitch if there was some thing odd, and again nothing odd showed up. At that time i hat CIS v6 do a full scan and it showed my system was totally clean.

After that i also ran a scan with OTL and TDSS Killer, yet again no problems reported. Then i decided to remove CIS v6 and reinstall CIS v5.12. After installment and configuring it, i restarted my system and look and behold the load on my CPU and RAM where back to normal again. And browsing was as fast as before to.

So i will wait a while, to see how v6 matures, and by that time if i like what can read here i will try v6 again. Also please do not think i blame you or some thing like that, i know from past experience that certain versions can work differently on each PC.

Hmm would be really good if you could report that CPU usage as a bug, and take a dump of whatever process is doing it. Which was it BTW?

If you can bear to reinstall that is.

If the CPU continued after the full scan then it won’t be the caching scanner, which I would otherwise suggest. If it were that it would settle down.

(What’s your OS/RAM/CPU BTW?)

Best wishes


Sorry mouse1 but at the moment i do not have the desire to go through the un-install - Reinstall - un-install - reinstall process again. :frowning:

But the CPU usage was the same after the full scan with v6. As for your other question…

OS: Windows 7 Home Premium 64 bit
CPU: Intel(R) Core™2 Duo CPU E7300 2.66 Ghz

THat’s OK what was the process consuming all the CPU & RAM?

Well all i saw was that the CPU load was constant between 50% to 60%, and the RAM usage around 40% to 45%. After having reinstalled v5.12 the CPU usage was back to 2…3% and RAM usage to a max of 32%. Of course those numbers are when the system is idle, when browsing/gaming or using other software it will be more of course. :slight_smile:

OK if you re-install and it happens again please do another bug report

I’ll format to non-format tomorrow, for the moment.

Many thanks


Once i do reinstall CIS v6 and it happens again then i will make a new Bug report, and thanks mouse1.

No probs


Thanks very much for your issue report. We have moved it to the non-format bugs board for the moment, because too much of the information we normally need to replicate a problem and fix it is missing, or it is not in the format we request.

We realize some people may not have the time to do bug report in standard format, and therefore offer the option of a non-format report instead. But the problem is much more likely to be fixed promptly if you edit your first post to create an issue report which meets all criteria in the Checklist and Format. (You can copy and paste the format from this topic). The general reasons why are summarized in that post, the reasons we ask for specific pieces of information are given in this detailed post.

You can get your report moved to the format verified issues board simply by ensuring that it is correctly formatted and all criteria are met, and PM’ing a mod who is active on the bug board.

Best wishes


Can you please check and see if this is fixed with the newest version (version 6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Also, note that all bug reports in the Non-Format section of the forum, which is where this report currently is, are not looked at by the devs. Thus, if the bug you were experiencing is still not fixed please edit your first post so that it is in the correct format (found here, with all required attachments, so I can forward this to the devs and get this problem fixed.

Thank you. PM sent.

Please copy the format provided in this post and put in your reply after the semicolon for each line. If you do this I can better hopefully forward this issue to the devs and get it fixed.

Thank you and be sure to let me know if you have any questions.

Done, and hopefully it is in the right format this time. :slight_smile:

Almost everything is there. I’ve moved this back to the normal Bug Report section.

For section B7 please state which of the programs is currently installed and which were previously installed? Also, please check and see if the problem persists even if all of them are disabled?

In addition, please attach the diagnostics report, even if it finds no issues, and the Watch Activity Process list (created through KillSwitch) to your first post. Please let me know if you have any questions at all.


Done…i hope.

Everything looks great. :wink:

Just one more thing though. Please temporarily disable both SpywareBlaster and EMET. Then restart your computer and let me know if the right-click scan still doesn’t work.

Once you’ve done that I can forward this to the devs.

Thank you.

Well i disabled all protection from Spyware Blasters, and unchecked EMET in auto start. Then i rebooted and tried to see if that solved the problem…well it did not solve it. :frowning: