Return the HIPS Enable/Disable Option to the Taskbar Icon

1. What version of CIS, or Comodo Firewall, are you currently using:

2. What actually happened or you saw:
I greatly lament the disappearance of the old taskbar icon feature which allowed me to quickly enable/disable “Defense+” (HIPS specifically). With the new user interface, only the Firewall and Sandbox can now be quickly enabled or disabled via right-clicking the taskbar icon.

3. What you wanted to happen or see:
When I right-click the Comodo taskbar icon, I want to be able to quickly enable or disable HIPS the way I used to be able to. I now need to go through a maze of options to enable/disable HIPS inside the Defense+ Advanced tasks.

4. Why you think it is desirable:
I am a software developer. Having HIPS enabled interferes with software development, but I want it enabled for all other tasks. So I need to constantly disable HIPS whenever I compile and run my programs, then re-enable it every time I am doing other tasks, such as browsing online help documentation for a project I’m working on. I am now constantly going through a maze of features with every enable/disable, whereas it used to take a mere second or two of my time. It now honestly requires a couple of minutes per enable or disable, more careful reading (diverting my attention from coding), and around a dozen clicks.

5. Any other information:
I hope other software developers catch this and vote to return this very handy feature!

if you right click on the tray icon and click advanced view then right click on the tray icon again the HIPS shown. Since HIPS is only for advanced users i dont see comodo changing this behavior

As wasgij6 pointed out, this has already been implemented for users who have switched to Advanced View. Thus, I will move this request to Added.

Let me know if you have any questions.


Ah, thanks! That solves the problem. :slight_smile:

I forgot to mention, I find it necessary to disable HIPS when both installing new programs and performing general software updates as well. So lacking this feature (or the knowledge of how to make it appear, at least), was a big nuisance. Glad it was not removed. :slight_smile: