Restore failed with error code 64

Have just installed windows 7. I made a backup under XP SP3, but restore keeps failing. Error 64, destination in use, it says. This is regardless of whether I restore to hard drive, portable HD, or even change to another computer. Am I doing anything wrong?

Is the XP to Win 7 causing a problem?

Please help - I am actually in a pretty bad position if I can’t restore this stuff.



A follow-on from my previous message - it’s error code 46 - i.e. path invalid. What does that mean, and how can I correct it?



We need more information:

What kind of backup have you made? Disk/partition/files&directores ?
Is the backup stored on an external hard drive?
I assume a restart is required for the restoration, but some external hard drives may not be visible when restoring at windows start-up.


The files are stored on an external hard drive. I ran chkdsk to see if there were any errors on both internal and external hard drives, no problems reported.

When I start restore it works for about half an hour, and then I get prompted error 46 - do you wish to restore on boot? When I click yes, it reboots, reports restore 100% complete, and then error 46.

I have experimented with using default destination for restore, or specifying different directories, or even restoring onto the external hard drive, but all seem to produce the same error (destination in use - error code 46).

If you could suggest a work-around i would be most grateful.

Hello - I finally got Comodo Backup to restore my files. I am posting this to suggest possible work-arounds for people in the same position (when restore aborts before completion).

  1. Alter Windows power save settings to never sleep / power off for hard drive and monitor before restoring.
  2. If you struggle with error 46 (file in use error) move the backup file to an onboard drive (c:) rather than an external drive
  3. Pull the network cable out of the PC or disable networking.
  4. Check that MS update isn’t trying to install something
    (last two steps to avoid Microsoft running something in the background)

Hope this helps ;D

I too am getting error code 46 upon reboot when doing a restore of a few files. I copied the backup file to the c: drive and the restore completed successfully. However, the computer will not restart when “pressing any key” as instructed. I have to shut down and restart the computer using the reset button. My external hard drive is a Western Digital 1TB (WD 10EADS External USB). I am running WIN7 (upgrade from XP).

Moving the backup file to the C: drive is doable (but would prefer not) but having to hit reset after restore is a problem. Any suggestions?


Do you have an USB keyboard?
Some types of the USB keyboards are not available at windows start-up, when restoring.


Yes, I do have a USB keyboard. Its a fairly new Dell.

I restored some files today and had to copy the backup from the external to the c: drive to complete. (cumbersome) Upon restart, the usb keyboard is not available at startup, so the key restart does not work. I have to press the reset button to restart, which throws the system into chkdsk by windows to verify disk integrity. Backup completes but what a cumbersome sequence. Short of buying a non usb keyboard, anyway to clean this up?