restore cpf settings in new beta

I don’t know if that one is gonna help anyone here, but anyway I just tried it and it worked fine:

1 go to [HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo] and export it
2 uninstall old cpf version
3 reboot
4 install new beta
5 unprotect registy keys from inside new cpf
6 exit totaly cpf
7 merge your exported reg file
8 launch cpf again and see that all your old settings are back(monitored apps + components +network rules etc…) but protection strength shows “bad”, component monitor is off
and you can’t turn it on, application monitor is off and you can’t turn it on either.It doesn’t
matter, just reboot…
9 login to windows, click on the cpf tray icon and see that everything is back to normal.

and don’t tell me that it’s a problem to reinject applications and components from the old
cpf installation because if you install the new beta just after uninstalling the old one, then not much
must have changed in your system.

that’s it. Good luck!

I’ve tested my system in those conditions for more than hour now: np.

Nice that it worked for you.
You can also use this script if you don’t want to mess with the registry manually.,2366.0.html

I have used CPFBackup and it worked fine.

I wish you add this feature into Comodo ones.
Kerio has an export feature, but not the rules :stuck_out_tongue:

Just one other thing to that could be added to the list.
If you want to take the settings and rules saved by the script from one PC and apply them to another PC on the same home network.

When I used to have ZA as my firewall I could take one backup copy and restore it to another PC with the same firewall on the same home network then just go in and change the PC name or IP and ZA would let you work with the rules. Well, with CF if you back up one PC using the script then put it on another machine with a different name or IP it won’t let you change the rules even though the protect the registry checkbox is unchecked.

What I found out was if you just change the firewall from Custom to Allow All by right-clicking the firewall icon in the system tray and then uncheck the Protect the Registry Keys checkbox it will let you change the machine name or IP in all of the rules. Then all you have to do is put the firewall back to Custom and recheck the Protect the Registry checkbox then restart like you said.

Just thought I would add this in as it can save a bunch of time setting up multiple machines that use the same rules on a home network.

Hope this helps someone.

jasper ;D

Are there any issues when restoring settings from an old 2.3.* version?

Shouldn’t be any problems; many users have done it…