[Resolved]Update forever 'installing'.

Have been using CIS Premium for some time, but, Today, & yesterday, on ‘Updating’ I get a window showing ‘Copying cfpupdat.exe file’ which is using 98% processor power.
It has been running nearly 2 hrs. There is nothing suspicious happening, & no net use, so what is it doing?

For two hours?

Cancel; then restart and try again;
Does this help ?


Cancelled yesterday, & tried again, result same. Am doing again, now, but so far, is still running as before.

Do you have any other security software running? also What OS are you using? (WinVista/7/XP)


No other security running, Win 7 64bit system. Duel core processor. No problems other than this anomily. May later try complete uninstall CIS. & re-install. But I know I will then have lengthy updating to do.

Not necessarily;
You could try a method before doing so;

Exit CIS (Right click icon > exit)
go to start > run > cmd > del /f /s /q %temp% Close once completed;
then browse to %programfiles%\Comodo\comodo Internet security
and right click run as admin > cfpupdat.exe

then try running the update that way;

hope this helps


Tried process suggested. Am running as Admin anyway, but tried. Nevertheless, after 10 mins of it running again as before, I don’t think there is any change to the problem. Feel I have no choice but to complete clean & re-install. Will use Revo Uninstaller to try best cleanup. Annoying, but I know CIS will not work properly if I don’t.

A clean re-install CIS Premium solved the problem. It had been running smoothly & doing it’s job correctly, so I can’t see a reason the update was not running properly. 5x times. Anyway, on re-install, the updates ran smoothly & quickly, inc the big problem one! A time consuming nuisance, but cleared up now.

Ok; Thanks for reporting back!

Re-Install is always a great method of fixing the problem :slight_smile: