[Resolved] Ran Registry Cleaner, System won't boot - HELP!!!

Hi. I’m new to this so please help me! I ran the Comodo registry cleaner on my emachines Windows XP PC. It found over 1500 items and I believe then suggested I compress the registry. Then it wanted me to reboot (or maybe it did it - I only saw those menu’s once) and now I can’t get back into my PC.

When I reboot, I can only get as far as the PC trying to load Windows. It gets stuck on the blue screen w/the windows logo in the center.

I can get access to F2, F8 and F10. I do not see anything in there that would allow me to get to a DOS prompt. I saw another user who may have had similar problems, and he deleted a couple of files and it seem to fix his. So I was just trying anything I could.

I am running Windows XP and do not have a start up disk. I do have recovery disks … but am concerned about losing data. We have lots of pictures. The recovery disk has 2 choices, Recovery which makes a copy of data and reinstalls windows (but I’m not sure that would fix the problem) or full reformat/trash the hard drive and start over.

Have I totally lost my who PC now? Please any help is appreciated!!!

P.S. MY pictures are on PC #2 and get backed up routinely. These are my teenage daughters pictures and she’s going to kill me!!! >:-D

OK, I couldn’t figure out how to add to my previous post, so this is a continuation of my post of this morning. I have not received any replies at this time.

I was able to get to a dos prompt and was able to go to the root drive of C:

The only thing there is one directory called system~1 and it is empty. No files anywhere. I know this hard disk was partitioned into C and D drives. It does not recognize the D drive.

What did this software do to my hard drive and what can I (or YOU) do about it? Please respond!

I am on facebook and I will post my experience.

Welcome to the forums, softballmom; sorry you’ve having such a rough time.

One of the cool features of CSC is that with its “Safe” mode enabled (which it is by default), no changes are actually made final until after you reboot the system and log in. At that point it will prompt you to finalize the changes. You shouldn’t be experiencing this issue as a result of running CSC.

As with all computer issues, it is possible that something went wrong with: CSC, some other application, a combination of the above, or something else entirely. Not very reassuring, I know, but strange things do occur.

Regarding your current dilemma… it would help to know precisely what the “recovery” disks are. Can you be more specific? Do you have a single CD, multiple CDs, etc? Are they Microsoft CDs, or from your PC’s manufacturer? A true “Recovery” disk would be made by the user for use with Microsoft’s Recovery Console, and that normally doesn’t happen…

A typical manufacturer CD is just an XP installation CD; it will give you options to Install or go to Recovery Console. From the Install option, there’s another option a little further in that allows you to repair your current installation, which does not format the drive, but only reinstalls the existing operating system files as they were when the system was first installed. This is NOT the same as a Repair Installation (also offered as an option on the CD); you do NOT want to do a Repair Installation.

With a little more info, I am confident the users here can get you taken care of and back up and running.


PS: I’ve merged your topics and moved to an open board.

hi softballmom,
please try to boot your pc pressing F8 and select “last known good configuation”

Selecting last known good config from F8 was one of the first things I tried - to no avail.

Update: I was able to get to my files (WHEW, they are still there!) and copy to external hard drive through the night. I’m ready to figure out how to hopefully restore the applications the way they were, but if that doesn’t work, I’ve mentally accepted that I may have to reinstall windows/apps etc.

A friend suggested running this: %systemroot%\system32\restore\rstrui.exe

I do not have original windows xp disks as they did not come w/PC (already installed on hard drive). I DO have the 4 recovery CD’s that it told us to make when we first brought PC home and turned on. I will try that recovery option next. (Not the reformat the whole hard drive option, but the reinstall windows option). This option was described as backing up data to another location, reinstalling windows, then moving data back. I assume then, the only applications that will be on hard drive at that point will be the ones original to the PC. Is this correct?

Any suggestions? I’ll be working on this all day today. Thanks.

And does anyone have any idea of what actually happened yet? I’m still curious as to what the conflict was with the software and my PC. And I believe there was most likely some sort of conflict. Thank you.

Clear the CMOS . good luck

I don’t know what "Clear the CMOS means. Can you elaborate please? :slight_smile:

Option #1: Mechanically Removing the Password

Most motherboards manufactured over the last decade or more use a battery to sustain the dynamic Bios/CMOS settings for the motherboards PROM chip. These dynamic settings are those manually set by either the computers manufacturer or you, the user. There are two ways to erase these dynamic settings, by either resetting a jumper on the motherboard itself (referred to as a “clear CMOS” jumper), or by physically remove the power from the computer (disconnecting the power plug) and then removing a battery (used to maintain power to the PROM chip that contains the Bios/CMOS information) from the motherboard.

Motherboard Jumpers:

Some, but not all, motherboard manufacturers provide a set of three jumpers on their motherboards that provide you with the ability to clear the Bios/CMOS settings, thereby allowing them to be reset. For the most part this is used when the Bios/CMOS data becomes scrambled and you need to clear the Bios/CMOS in order to return the computer to a functional state. This same procedure, however, can be used to clear passwords from the Bios/CMOS setup. Typically a jumper will be found across pins #1 and #2 as the default position, and by shutting the computer down, unplugging the power cord and then moving the jumper so that it is across pins #2 and #3 will clear the Bios/CMOS settings.


Hi softballmom

First off, I too have no idea what the relevance of clearing the CMOS is to your issue would be and descent doesn’t even explain why it would be.

But to come to an important point: trying to use ‘Last Known Good Configuration’
I can tell you from long experience fixing many many systems that it can take as many as TEN ATTEMPTS to get a Last Known Good Config to actually work so my advice is to persist with trying via Windows Advanced Options to get a Last Known Good Config to work by trying it at least 10 times.

Interesting point. So each time you choose “last known config” it may go to one before and the one before that? Ok, I’ll try that now. Thanks for the tip.

ok, I am trying to press F8 to get to the option of using last good config, and now PC is getting stuck “earlier” than before. Prior it would get past the “e” (for emachines) screen where the options for pressing F10 and F2 are mentioned then would proceed to get stuck on the blue screen loading windows. Now it is stuck on the “e” screen.

Will keep trying.

I have the Bart PE bootable windows disk that I used to get in to copy my files to my external hard drive last night. Wondering what else I can do with the options they offer. Anyone know anything about that?

Got back into boot disk menu’s and found the rstrui.exe file. First time I tried to run it, said it couldn’t find the .dll. So I went looking and the .dll was in the .dll directory. So was another copy of the rstrui.exe file. So I tried to run it from there and nothing happened. Then I copied the .dll to the windows/system32/restore directory where the original rstrui.exe was - and tried to run it, and nothing.

Any other ideas?

Have you read this topic.

Thank you for the suggestion. Yes I saw that, but I had not tired that yet. Just went now and those files are not there. I looked in the windows\system32\drivers directory and the windows directory for the bin file and neither file was there. In the windows directory, there are

Looked for CRPF.SYS in Windows\System32\Drivers folder and it is not there (there is a cdfs.sys - but not the same thing obviously).

Looked for CRPF.BIN in the WindowSystem32\Drivers folder and it is not there.

Looked for both of these in the \Window folder and they are not there either.

In my Windows folder, and maybe they are supposed to be there … I have well over 100 subdirectory folders that are similar to: $NtUninstallKB885250$. I am assuming these are probably related to all the updates over the years.

Any other ideas? I never did find any .bin files in either of those directories - not sure if that is a red flag or not.

Any more ideas please?

Up to 19 reboots / selecting use last known good configuration …

could you please try and disconnect all devices exept keyboard mouse and monitor.

can you use safe mode? run this command: chkdsk /f
answer Y, reboot and give it plenty of time.

assuming you tried safe mode, then there is some file missing which will need to be replaced from cd.

i gave up using csc after 3 reinstalls! Won’t use it again unlike cis which is great.

You sound quite experienced then. Any suggestions on getting my system back up and running? Am I at the point I just have to reinstall everything?

I gave up and reinstalled.

I have given up too and have reinstalled. Now going through the headache of getting everything else up and running. Thanks for commiserating.