[Resolved]No Internet if "Protect ARP Cache" enabled during connection[v5]


When trying to connect to internet with my laptop if there’s “Protect the ARP Cache” option enabled the connection won’t work. It can connect to my router but no internet. To make it work I have to disable Arp protection, then connect. So I can enable that option only when I’m already connected and do this workaround every time I have to riconnect (eg. suspension, reboot…).
-firewall log and D+ log don’t report anything about it
-disabling Avira Antivir doesn’t solve

My set-up
-Comodo Firewall v5.0.163652.1142 x64 (updated from v4 by auto-update), Proactive Security
-Firewall Behavior Settings: Custom Policy Mode, Protect The ARP Cache, Block Gratuitous ARP frames, Do protocol analysis enabled. Alert settings “Very High”
-Defense+ Settings: Safe Mode, Execution Control Settings, Monitoring settings all enabled
-Sandbox enabled
-Windows 7 Home Premium x64, UAC enabled (default), administrator account
-Avira Antivir Free 10
-Router Netgear DG834Gv5 (DHCP disabled)


Hi Randext,

I how many networks do you use your laptop?
And do you use hibernate/standby to “hop” from one network to the other?

Hi Ronny,

I have only one network and I don’t use standby for that reason.

Can you boot the system so that it won’t connect.
Can you type the following commands in a “command box”?


arp -a
netstat -rn

And PM me the results?

Ok, PM sent.

There doesn’t seem to be a bug here, user has a Duplicate IP address conflict on the local LAN.
There are two different MAC addresses claiming the same (default gateway) address.

So ARP protection is working fine, and doing it’s job.

Edit:
Mods; Please leave the post here until the user can confirm the issue is solved, and the dev’s have the time to see that there is no work to do here…

I can confirm it’s not a Comodo’s bug.
I have a WDSL antenna with the same IP of my router.
Problem solved, thank you for support!

Moving now to resolved issues.

Best wishes

Mouse