[RESOLVED] Incredimail and network security policy

I use Incredimail. I set it up as an email policy or treat as email, but it keeps changing to custom or web browser. Whenever it comes up with the screen to ask what t do there is no treat as email listed. I have to go into firewall network security policy and change it every time I want to send an email or it fails.

How can I get it to keep the policy I want?"

Hello Welcome to the forums.

There are 2 types of Pop-Ups, Defense+ and Firewall.

You should be given the option to make the program “Treat as Email Client”
And for Defence+ “Treat As trusted application”

You can further modify of view the programs as you wish;
Comodo-> Firewall ->Advanced → Network Security Policy
Comodo-> Defense+ → Advanced → Computer Security Policy

And if you wish to see the predefined policys, Or make your own you can do this;
Comodo-> Firewall ->Advanced → Predefined Network Security Policy
Comodo-> Defense+ → Advanced → Predefined Computer Security Policy
May edit or creat your own.

Hope this helps!

Thanks, but these aren’t working.

The “treat as email client” isn’t there for the firewall even though there is a predefined email client. I keep editting the 2 entries for the Incredimail program in the network security policy, but every time it retrieves my email the firewall pop-up comes up. With no treat as email option it usually reverts to custom. I really like this program and this is the only problem I’ve had, but I have to edit the policy twice and hit apply for each outgoing email I want to send. It can be a major hassle some days.

Hello.

I use Thunderbird, How ever it should work just the same regardless of what email client you use.

I have set Thunderbird as an Email Client VIA network security policy and then when Thunderbird connects I get aleted to which IP it is trying to connect to, I click allow and remember answer and then when I look at my network security policy it says “Custom” That is Okay, It was orginaly an email client and the only thing that has changed is With the pop-up to connect outbound I clicked Allow and remember

See attached picture.

[attachment deleted by admin]

[attachment deleted by admin]

Yes the predefined firewall rule is “email client” if for some reason you need to allow a pop up (remember answer) it will change to custom. (it probably adds- allow ip out to any, any any) Leave it like that, you’ll be fine or edit the predefined rule accordingly. That’s how it works for me in Thunderbird.

Added: I see Kyle said the same!

I have something else wrong here then because when it changes to custom I can no longer send outgoing emails. It should work the same for Incredimail, so it must be something else I changed and just don’t knw what.

Thanks for your help though. I appreciate it.

Take a look at the attached modified rules for Email Client. The default Comodo rules do not make provisions for http email, which Incredimail appears to use a lot. Use these rules for your email client, then look at your log if you have further problems, since other attempts by Incredimail that fail should show up there as being blocked.

[attachment deleted by admin]

HTTP and NNTP are not options for protocols so how do I get them as options?

They are both specific instances of tcp.
You can copy http from your web browser rules, but http is: allow/tcp/out/any/any/any/80
If you have a set of http ports listed under “my port sets”, you should point to them instead of port 80.
You can leave out the nntp line; it is for newsreaders, but would be
allow/tcp/out/any/any/any/119
I have it because most email clients/newsreaders are combined
If Incredimail uses other http ports, they should show up as blocked in the log so you can add them to the http destination ports.
Sorry; not an incredimail user so may need another iteration when we see the log. :slight_smile:

Thank you it solved my problem. I forget thatincredimail uses http and would never have thought of it.

Thanks again. :BNC

Glad it is working for you. I’ll mark this topic resolved then. :slight_smile: