[Resolved]DHCP Blocked

I just got a new Windows 7 notebook and I have had numerous networking issues. The computer is unable to contact the DHCP server on my router. In the command prompt, I tried ipconfig /renew and got the response “unable to contact DHCP server.” I happened to look at my firewall events and saw three of these

Application: C:\Windows\System32\svchost.exe
Status: Blocked
Protocol: UDP
Source IP: 192.168.1.164
Source Port: 68
Destination IP: 192.168.1.1
Destination Port: 67

Is Comodo blocking my computer from communicating with my router’s DHCP server?

Hello;;

Could you try Comodo Forum

and report back :slight_smile:

Thanks
Jake

That didn’t work for me but I think I have fixed it. It was… surprise, surprise… user error. I had svchost.exe treated as Web Browser. Not sure how it happened but I changed it to Outgoing Only and now things are much better.

However, I would suspect that doing “ipconfig /renew” in the command prompt should give me a new IP address. It doesn’t. It doesn’t give me the “unable to contact your DHCP server” error any more but it doesn’t give me a new IP address either.

Also, and this is surely not the correct forum but, my router runs DD-WRT and I tried to give my computer a static lease but that did not work. This is something I have done with previous computers.

Thanks for the help and if you know anything about “ipconfig /renew” or static leases, I would appreciate the info.

Its up the DHCP Server to give you a new IP, ‘ipconfig /renew’ just re-establishes the IP address.
So if you have a router and you use ipconfig /renew, i’m sure that you won’t get a new IP (Private IP that is) It’s up to your ISP to give you an Public IP

Hope this clears up

Did i answer all your questions? :slight_smile:

Thanks
Jacob

Yes. Thanks for the help.

Thank you for visiting the Forums :slight_smile:

%lock%


Thanks
Jacob