[Resolved]Comodo firewall blocking Java Web Starter

I have Comodo Internet Security installed on a Win7 64bit machine. Comodo is blocking Java Web Starter, so I can’t open the AppInventor Blocks Editor if the firewall is on. If I completely disable the firewall, I have no problems.

What I can’t figure out is how to configure the Comodo firewall to allow Java Web Starter to start. I’ve added every javaws.exe file I can find to the Trusted Application list. I have no problem with any other Java based content… just the Web Starter.

I’m sure I’m not the only one it run into this problem. Did anyone else solve it and is willing to share?


I think I am having the same issue! I have been trying to play a game that requires Java to load, I get the icon in the bottom tray, but none of the games load. It just shows “Loading… 0%” forever. It worked before I installed Comodo, and it works on my other notebook (not running Comodo). I have disabled everything to try, but it still isn’t letting it get through.

I also have a problem opening Java with the newest version of COMODO Firewall (version 5.0.163652.1142). I have a 64-bit Win7 system with IE 8 . In attempting to initialize a streaming quotes software on www.scottrade.com, I OFTEN receive a “spash: recv failed” error message and the platform fails to download to my computer. I have taken the step to add “javaws.exe” to the trusted application list, but failure occurs regularly. I can eventually get through, but it take several attempts.

Tech support at Scottrade suggested making sure por 443 was open. I ran the test available on Microsoft and that port is open, so that is not the problem.

Any other ideas as to how to get around the problem.

is the following process as possible?

right click
run as administrator


roswitina - I gave your suggestion a try for a few days, starting www.scottrade.com as an .exe located on the desktop where the administrator is one of the listed accepted users. It took from one to three times to get past the splash error…which actually is an improvement…but it is not a consistent fix…looks like I can only hope COMODO addressess the issue some day…but it’s been around for several years, so they don’t seem to see it as a real problem to address beyond the Trusted Files non-fix. If the hassle continues or get worse, I’ll probably review my firewall options when COMODO renewal time comes up. Thanks for the suggestion.

Hey and warm welcome to Comodo forums, roswitina and tasmica! :slight_smile:

have toy tried to add it in application rules? you can also try to added it in exlusions of detect shellcode injections (CIS —> Defense+ —> Defense+ Settings —> Execution control Settings —> Detect shellcode injections (i.e. Buffer overflow protection) —> Exclusions —> Add —> Browse…)

Enjoy your stay here at Comodo forums :slight_smile:

Valentin N

Thanks for responding, Valentin…I have added the javaws.exe executable to the “Detect shellcode injections” option under “Defense+ Settings”. I tried it a couple times this evening and so far, so good.

I’ll be using it over the next few days, so I’ll report an update when I have more experience using the exclusion options…

I had not seen this “fix” before, so, if it continues to work successfully for me, I hope it gets further distribution to other people encountering this issue.

I’ll go ahead and close this thread;