[RESOLU] Soucis de connexion avec Steam

Salutations.
Voilà, j’ai (trop) régulièrement des soucis de connexions avec Steam. Steam, lui se lance, télécharge rapidement mais c’est au niveau des jeux que tout se complique. J’ai assez de mal à diagnostiquer cela. Laissez moi vous en faire part : Team Fortress 2 est ma bête noire, il marche quand il le souhaite. Des fois tout va bien, des tas de serveurs, un ping excellent… et la majorité du temps : rien, pas de serveurs, connexions impossible (je précise que CS a le même problème (HL2.exe ?)). Ok… D’un autre coté, marchent toujours et sans jamais m’embêter Left4dead, CoH, DoW, etc.
J’ai épluché les tuto du web : j’ai paramètré mon routeur, désactivé son Firewall, ouvert les ports sollicités par Steam et Half Life2. J’ai fait de même pour mon firewall (software). Je n’ai qu’un firewall qui se nomme Comodo (évidement ^^). J’utilise comme antivirus Avira Antivir.
Donc, ceci étant dit, je suis vraiment à court de solution. Avez-vous une idée de ce qui pourrait empêcher les programmes liés à Half Life 2 de se connecter correctement ?
Je vous offre d’autres informations, qui peut-être pourront-être utiles :

  • FAI : Numericable (modem Netgear CVG834G) 30mb.
  • Le firewall physique (routeur) est désactivé.
  • Les ports ouverts sont les suivants : TCP/UDP : 1200 ; 27000-27015 ; 27020-27039.
  • Le HIPS du firewall (software), désativé, ne change rien au problème.
  • Les règles pour les programmes liés à Steam sont crées (accès sans restrictions… “trusted application”).
  • Aucun problème de connexion n’est constaté avec les autres applications. Seules sont concernées Tf2 et Cs:s. Ces deux applications sont liées à hl2.exe.
  • Le firewall Windows est désactivé.
  • J’utilise Comodo en V3.
  • J’ai utilisé le Firewall en mode apprentissage, le problème persistait.
  • Les services suivants de mon modem routeurs sont restés activés : Ipsec PassThrough, PPTP PassThrough, Multicast.

Voilà, je vous demande donc de l’aide pour paramétrer Comodo avec hl2.exe, je ne sais plus quoi faire actuellement :-\ Je me doute bien que ceci est une question récurente, mais de toutes les réponses/aide que j’ai vu : aucune n’a fonctionné. Soit, encore plusieurs utilisateurs sont sûrement encore dans ma situation. N’arrivant vraiment pas à diagnostiquer ceci, je demande de l’aide pour configurer Comodo, peut-être ceci m’aidera.

Je vous remercie de m’avoir lu, et j’espère que vous pourrez m’apporter de l’aide. Je ne vois aucun inconvénient à changer (encore)les paramètres de mon firewall et à tester vos idées :).
A bientôt,
Sukiyaki.

va dans “firewall” puis “define new trusted application” et ajoute hl2.exe, gameoverlay.exe, steam.exe et tout les .exe de tes autres jeux steam
va dans “defense +” puis “my trusted software vendors” et fait “add”->“read from a signed executable” et ajoute steam.exe
en faisant cela la défense + autorisera tout venant de valve et ton pare-feu laissera tes jeux passer
re-dit moi si sa marche car cela peut aussi venir des regles “attack detection settings”

Merci de ta réponse, Florent.
Cela marche déjà mieux, je peux me connecter plus régulièrement, mais après avoir déconnecter d’une partie ou du jeu, lorsque je relance le hl2.exe : le problème refait surface.
Je n’ai rien touché au niveau des règles “attack detection settings”. Si il y a des réglages à faire, je t’écoute.
Merci encore pour ton aide, je peux au moins y jouer un peu :).
Niveau de sécurité actuel : Firewall en “safe mode” et Defense + en “clean pc mode”.

edit : après avoir rejoins une partie ou actualiser les serveurs une fois, il est impossible de faire le refaire une seconde fois. La première connexion sur le jeu marche, une seconde tentative me ramène au précédent problème.

j’ai fait des tests, pas de soucis chez moi
css nickel, tf2 met lgt a lancer un serv mais il se lance
met les rapports au format html dans ton prochain message
va dans firewall, view firewall events, more et exporter au format htm
va dans defense +, view defense + events, more et exporter au format htm

Ah, voilà ! J’ai repris toutes les règles une par une et tout marche parfaitement. Rafraichissement rapide, aucun problème de connexion.
Je te remercie de ton aide Florent, c’est très aimable.
Et enfin : mes “firewall events” sont vides, donc tout semble marcher correctement.
Encore merci :),
Sukiyaki.

pas de soucis :slight_smile: