Hi. Totally new to Comodo Firewall, installed it for the first time today. Apparently I ■■■■■■■ up on my initial configuration, because after awhile Thunderbird quit working. I opened Comodo and could clearly see in the log that Thunderbird was being denied internet access; but when I checked everything else, only one program was shown as being denied access (a defragger); all mentions I could find of Thunderbird gave it a green light.

Ok, so I figured I’d just reset to the default settings and start over, but couldn’t find a reset button, except for the “Restore” button in “Security – Advanced”. It makes reference to just the settings on that page…?

Finally I uninstalled Comodo and started over. But it seems like there has to be a better way… doesn’t there?

Came here, did a search, and found one reference that seemed to indicate that there is no “reset”. I did, however, find mention of it on the “Wishlist” dated from last June. As several other of those suggestions have been implemented, I’m crossing my fingers a “reset” has also, and that I just can’t find it. Help? Thanks!

Welcome at the forums

Ther is a restor button under the advanced tab. :wink:

I figured that was just for that particular page ---- no? So if I click the “restore” button it will set the entire firewall back to ‘factory’?

Bump…I too have the same question…


My understanding is that the Restore button resets everything except the network rules. However, I have not tried it, so I cannot vouch for the accuracy of that statement. It may just be that page… You can try it and see what happens; if you do, please be sure to post your results here, for others’ benefit.

You can also turn off each rules monitor (Network, Application, Component), remove the rules manually (ctrl+click to highlight multiples). Then reboot your computer. This should clear out the files, and allow you start your settings over again.

However, if you have the time and don’t mind, uninstall/reinstall is probably the “cleaner” way to go, to start fresh (in the even your rules have really gotten messed up…).

Hope this helps,