Reset Sandbox task doesn't complete [M265] [v6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic title, NOT here.

  • Can U reproduce the problem & if so how reliably?: Maybe, it happens at random times. It has happened 3 times (that I know of) since February 1st.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    I can’t give exact steps to reproduce other than continuously sandboxing and resetting the sandbox.
    What I did was:
  1. Sandbox things.
  2. Reset Sandbox.
    The results were:
    a. The VTRoot folder in C:/ was deleted.
    b. The task is still going at it in the CIS Task Manager.
  • If not obvious, what U expected to happen: The actual task to finish.
  • If a software compatibility problem have U tried the conflict FAQ?: I don’t think it’s a software compatibility problem.
  • Any software except CIS/OS involved? If so - name, & exact version: No, there has been different things sandboxed each time it has happened.
  • Any other information, eg your guess at the cause, how U tried to fix it etc: Don’t know, the only fix I have found was to reboot. Simply shutting down Comodo and executing it again doesn’t fix it, the Task is still going.
  • Always attach - Diagnostics file, Watch Activity process list, (dump if freeze/crash). If complex - CIS logs & config, screenshots, video, zipped program (not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: 6.0.264710.2708 | Configuration is in attachment. (Proactive base)

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: HIPS - Off, AV - On, Firewall - Safe Mode, Autosandbox/BBlocker - Fully Virtualized.
  • Have U made any other changes to the default config? (egs here.): Yes, config is in attachment.
  • Have U updated (without uninstall) from a previous version of CIS: No.
    [li]if so, have U tried a a clean reinstall - if not please do?: I have already done a complete re-install, following the un-install guide on this forum.
    [/li]- Have U imported a config from a previous version of CIS: No, I always re-create my config instead of importing the config. I make my configurations on top of the Proactive config.
    [li]if so, have U tried a standard config - if not please do: Like I said above.
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, & VM used: Windows 8 64 bit, UAC is disabled, Account is administrator and no virtual machine is used.
  • Other security/sandbox software a) currently installed b) installed since OS: a) None. b) None

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


I’m going to piggy back on the back of this report as I believe they are very similar issues.
Killswitch screens and config are here -;msg667339#msg667339

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Because of the nature of this bug (seemingly very random) it’s hard to test if it’s fixed or not. I’ve been home since around 1st June and even though I haven’t performed many resets, the ones I’ve done have not gotten stuck, I don’t know what that means though, the issue could still be present though it didn’t appear the times I reset the sandbox, hence I can not say if it’s fixed or not but if it happens again I will post about it.

Okay, I’ll leave it flagged as a bug for now. If eventually you believe that it’s very likely that it is fixed I’ll move this to resolved. However, until then I’m happy to leave it sitting where it is.

Please keep me updated.


Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Well like I said, it’s very random however I have reset the sandbox quite a few times now and so far I have not gotten the issue. I think that the thread can be moved to the resolved section, I will post if it ever “fails” again. Thank you.

Okay. Thanks for checking it again.

I will move this to Resolved. Please send me a PM if the problem returns.

This old issue:I can confirm it’s resolved now. It resets perfectly and fast no matter the content of the sandbox! :slight_smile: