Reset can takes ages & when complete still continues in taskmanager [M363] [v6]

A. THE BUG/ISSUE: Resetting

[ol]- Summary When resetting the sandbox, task seems to start for ever but is quick to happen;when it completes, task still appear as “starting” in Task Manager and won’t go until rebooting. Problem happens randomly a few times after fresh install

  • Can U reproduce the problem & if so how reliably?: Yes, even upon clean uninstall and reinstall using both Norton Removal Tool and Comodo Uninstaller Tool as reported by Chiron.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened: Opened Dragon sandboxed (Kiosk), surfed a bit, then closed it and resetted the Sandbox.
  • If not obvious, what U expected to happen: A fast reset and then no resetting in Task Manager
  • If a software compatibility problem have U tried the conflict FAQ?: No
  • Any software except CIS/OS involved? If so - name, & exact version:May be Sandboxie v.3.76 (stable) because it also uses a virtual sandbox. Lately, I don’t think Sandboxie is involved.
  • Any other information, eg your guess at the cause, how U tried to fix it etc:No, tried the default installation in CIS 6, uninstalling then cleanly reinstalling but problem still there.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware).See below

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)

[ol]- Exact CIS version & configuration: CIS 6 version 2708 and lately v.2801(latest stable one)- Proactive security

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:HIPS safe mode/Bblocker at blocked/FW safe mode settings as by Chiron
  • Have U made any other changes to the default config? (egs here.):no
  • Have U updated (without uninstall) from a CIS 5?:no
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:no
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:Win 7 sp1 64 bits, UAC ON, ADMINISTRATOR, HP-Desktop model p6732f
  • Other security/s’box software a) currently installed b) installed since OS: a=SANDBOXIE 3.76, Malwarebytes v., Hitman Pro 3.7.3 build 193, Spybot Search & Destroy v.
    b= Norton 360

[attachment deleted by admin]

Problem was solved by uninstalling Sandboxie!!! :smiley:
Everything ok, now!
NB: Not so fast, it has nothing to do with Sandboxie ;D

For those who still need to run Sandboxie and also sometime a Comodo sandbox browser, the problem is solved by installing the latest Sandboxie beta, actually I tested version 4.01.05 64 bits! So you can keep both now! :P0l
P.S.: After less than 24 h, I uninstalled latest beta of Sandboxie also because the problem reappeared again. I’m better off with CIS 6 only!.. :smiley:

While (the resetting sandbox task) “weaky”, it’s certainly better without running Sandboxie on the same pc if you want to use also the Comodo Sandbox. Make your choice! ;D

I didn’t expect to reply but I had more to say about the resetting task weirdness (sensitivity). Ok, the Sandbox resets, eventhough it seems to go for ever, but the tassk even when the process is gone after clicking “continue”, still says it’s starting (but it already runned…!). I have problems with latest version of Microsoft Silverlight v.5.1.20125.0 in running it in Comodo Sandbox. Unlike prior edition and running it unsandboxed (only way it sure works even with the latest version), I’m unable to use the controls or to send it full screen. I tried installing the last beta (outdated) and still buggy I was able to run full screen. But my browser was yelling it was outdated and unsecure. So I updated Silverlight before resetting the Sandbox. Hitting the reset button brought me to my problem, solved by uninstalling Silverlight and rebooting. Reset was now correctly working…

Got a be “crazy”!!! I reinstalled Sandboxie 3.76 (the beta one is still too much buggy). Guess what? The resetting works perfectly well. I don’t understand. Sometimes the task goes on starting and never ends, sometimes it behaves normally! ???

Are you sure that it’s related to Sandboxie? I get the same problem (you can see my bug report here to see if you think it’s the same problem ) but I have never had sandboxie on my computer. Though it seems to be “random” and doesn’t happen all the time so it might not happen for perhaps 50 resets but then BAM!

Yes your bug report is ok, but I have another so called dysfunction in the Comodo sandbox with the Silverlight that tends me to use sandboxie rather than the Comodo Sandbox and Google Chrome rather than Comodo Dragon. It’s sad! :cry:

Sorry for delay in reply. This is made very complex by the amount of security software you are running.

Could I suggest you try all the recommended options in my FAQ here and report back.

Meanwhile I will temporarily transfer you to help, if that is OK. We can move back later if these suggestions don’t help you.

Best wishes


From the information you have given I am not clear whether this is a bug/issue.

For the moment I will transfer you to help so you can work through this issue with users and mods in this forum and hopefully resolve it. I hope that is OK.

Please ask any mod to move this report back to the bugs forum if it becomes clear that it is a bug/issue.

Best wishes


Thanks Mouse1. With update to v.2801:PROBLEM TOTALLY SOLVED, even MICROSOFT SILVERLIGHT works as well as in Sandboxie v. 3.76 in full screen. I’m really happy and a proud Comodo fan and user now! Many thanks to the Community for precious help!!! :slight_smile:

Yes some conflicts were resolved :slight_smile:

Best wishes


If you run resetting sandbox with another task in task manager, the problem reappears even in v.2801. Had to reboot many times. Now back to normal. Note the resetting is normal, it’s only the task in task manager that is starting forever, and also to get to the final screen continue you wait longer (more than 5 minutes) than usual. For the Silverlight it’s same, it runned a few times correctly and today I can’t watch it full screen unless using it with Sandboxie browser or unsandboxed ???

Seems to be a bit unstable this affair with the resetting task end and full screen Microsoft Silverlight problem. Can’t find other problems for now. 88)
P.S.: Usually, resetting takes less than 1-2 minute(s) to finish. If it takes more, it’s a bug!

Thanks for the extra information.

Are any sandboxed processes running when this problem manifests itself?

(They may be holding on to file handles and preventing a reset)

No in fact, as soon as we hit reset, the reset is done but sometimes it still shows in the task manager it is still starting and it never ends until rebooting! :slight_smile: I managed now to reinstall cleanly two times CIS 2801 for the Silverlight bug but I haven’t got yet the resetting problem for now on. For silverlight, it appears to be linked between the Comodo Sandbox and Microsoft Silverligth 5.1. ???

Since I modified my bug report and I keep getting randomly the bug, can you please put this in the format verified bugs reports? Thanks!

I will move it back to the bug report forum where can be decided to move it to bugs verified.

Hi Gdiloren.

Just about to forward this and noticed that your Watch Activity process list was still missing. Could you add it please then I will forward this tomorrow.

Best wishes


Done. I even opened Dragon in Comodo Sandbox with Microsoft Silverlight running. It runned fine full screen the first time but when I went back to normal screen I wasn’t able to go back to the control nor the full screen anymore!

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again