'replacement' certificate not received

We purchased a certificate that was stuck in ‘awaiting validation’ until an agent in the online chat expedited the process; after receiving the certificate we discovered that we used the wrong csr and needed to replace the certificate. In the management web interface I clicked on ‘replace’ and pasted in the correct csr and submitted the request. I received an email for another validation and provided the new code into the textbox on the page of the provided url. The response was that the code was correctly entered. After hours of waiting no certificate was received (domain comodo.com is whitlisted for email) so I tried many times
again to ‘validate’ and received the same response from the site that the entered code is correct. Still have
not received a certificate.

  1. do I need to ‘revoke’ the old certificate first?

  2. do I need to pay for another certificate in order to replace the first one?

  3. why can’t I log in to the support site with the email address for the certificate (using the password
    for the management interface)? I tried to register at the support site but received an error that
    the email address is already registered, yet when I try to log in I get ‘invalid email address or password’

This is friday evening and I need to get a working certificate for the site for the weekend.

  1. No, you do that AFTER you have a new certificate.

  2. No, no need to pay again unless the existing certificate is soon to expire.

  3. The support site, the forums and the certificate management interface all have separate user databases. Thus, no single sign-on. You have probably submitted a ticket before in the past thus you will need to click “Forgot Password” on the Support site, to reset your password.